LightOJ - 1236 Pairs Forming LCM (唯一分解+lcm)

Find the result of the following code:

long long pairsFormLCM( int n ) {
    long long res = 0;
    for( int i = 1; i <= n; i++ )
        for( int j = i; j <= n; j++ )
           if( lcm(i, j) == n ) res++; // lcm means least common multiple
    return res;
}

A straight forward implementation of the code may time out. If you analyze the code, you will find that the code actually counts the number of pairs (i, j) for which lcm(i, j) = n and (i ≤ j).

Input

Input starts with an integer T (≤ 200), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 1014).

Output

For each case, print the case number and the value returned by the function 'pairsFormLCM(n)'.

Sample Input

15

2

3

4

6

8

10

12

15

18

20

21

24

25

27

29

Sample Output

Case 1: 2

Case 2: 2

Case 3: 3

Case 4: 5

Case 5: 4

Case 6: 5

Case 7: 8

Case 8: 5

Case 9: 8

Case 10: 8

Case 11: 5

Case 12: 11

Case 13: 3

Case 14: 4

Case 15: 2

把n,m唯一分解,n=(p1^a1)(p2^a2)……(pk^ak)    m=(p1^b1)(p2^b2)……(pk^bk)

lcm=(p1^max(a1,b1))(p2^max(a2,b2))……(pk^max(ak,bk))

gcd=(p1^min(a1,b1))(p2^min(a2,b2))……(pk^min(ak,bk))

推导

#include <bits/stdc++.h>
using namespace std;
const int N=1e7+50;
int prime[N/10];///这里开1e6 否则RE (玄学 为什么??)
bool vis[N];
int tot=1;
void Er()
{
    memset(vis,0,sizeof(vis));
    vis[0]=vis[1]=1;
    for(int i=2;i<N;i++)
    {
        if(!vis[i])
        {
            prime[tot++]=i;
            for(int j=i+i;j<N;j+=i)
                vis[j]=1;
        }
    }
}
long long solve(long long n)
{
    long long ans=1;
    for(int i=1;i<tot&&prime[i]*prime[i]<=n;i++)
    {
        if(n%prime[i]==0)
        {
            int tmp=0;
            while(n%prime[i]==0)
            {
                n/=prime[i];
                tmp++;
            }
            ans*=(2*tmp+1);
        }
    }
    if(n>1)
        ans*=3;
    return ans;
}
int main()
{
    Er();
    int t,k=0;
    long long n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lld",&n);
        long long ans=solve(n);
        ans/=2;
        ans++;
        cout<<"Case "<<++k<<": "<<ans<<'\n';
    }
    return 0;
}

 

全部评论

相关推荐

04-15 23:42
中山大学 Java
ResourceUtilization:过几天楼主就会捧着一堆offer来问牛友们该怎么选辣
点赞 评论 收藏
分享
大猪蹄子哥:1-谁教你这么写教育经历的……咱都这个学历了,很多公司要看本科、硕士,Gap Year的,你啪就给一个上大26届硕士,没了。 2-那堆奖学金揉成一行放最后得了,放前面显得你没技术自信,还是那句话,对于咱这个学历直接上重点,你这上半段看起来像个大专(无恶意 3-专业技能最好点出来细化方向,你熟悉的以太网是UDP还是TCP,是千兆还是万兆等等,多种信号处理……那你倒是说两个啊,后面空着干嘛,会的干嘛不讲 4-项目经历废话太多,描述不专业(怎么还有我,我们这种词),没有数据支撑(是婴儿还是巨人看不出来)。最后如果这些是真的XX项目、比赛,最好点出来,不然更显得像自学着玩的,或者说抄的(经典复现等于我做过 5-个人总结在咱这个分段没用
点赞 评论 收藏
分享
评论
点赞
收藏
分享

创作者周榜

更多
牛客网
牛客企业服务