杭电 2602 Bone Collector——(裸)01背包、滚动数组

Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output
One integer per line representing the maximum of the total value (this number will be less than 231).

Sample Input
1
5 10
1 2 3 4 5
5 4 3 2 1

Sample Output
14

这是一道裸的01背包问题,也是最经典的一道01背包题目

#include <bits/stdc++.h>
using namespace std;
const int maxn = 1e5 + 10;
int dp[1010][1010];
int t, n, v;
struct node
{
   
    int vi, wi;
} w[1010];
int ans()
{
   
    memset(dp, 0, sizeof(dp));
    for (int i = 1; i <= n; ++i)
        for (int j = 0; j <= v; ++j)
            if (w[i].wi > j)
                dp[i][j] = dp[i - 1][j]; //不选
            else
                dp[i][j] = max(dp[i - 1][j], dp[i - 1][j - w[i].wi] + w[i].vi); //选
    return dp[n][v];
}
int main()
{
   
    scanf("%d", &t);
    while (t--)
    {
   
        scanf("%d%d", &n, &v);
        for (int i = 1; i <= n; ++i)
            scanf("%d", &w[i].vi);
        for (int i = 1; i <= n; ++i)
            scanf("%d", &w[i].wi);
        printf("%d\n", ans());
    }
    return 0;
}

滚动数组

  1. 我们可以把二维dp转换为一维dp以节省空间,我们观察二维表可以发现,每一行都是从上面一行算出来的,只跟上面一行有关系,与前面的行没有关系,那么用新的一行覆盖原来的一行就可以了
  2. 我们需要注意要把j反过来循环,也就是从后面往前面覆盖
  3. 优点:经过滚动数组的优化,空间复杂度就从O(NV)减少为O(V),动态规划题经常会给出很大的N、V,此时需要滚动数组,否则会MLE(空间超限)
  4. 缺点:无法构造最优解
#include <bits/stdc++.h>
using namespace std;
const int maxn = 1e5 + 10;
int dp[1010];
int t, n, v;
struct node
{
   
    int vi, wi;
} w[1010];
int ans()
{
   
    memset(dp, 0, sizeof(dp));
    for (int i = 1; i <= n; ++i)
        for (int j = v; j >= w[i].wi; --j)
            dp[j] = max(dp[j], dp[j - w[i].wi] + w[i].vi);
    return dp[v];
}
int main()
{
   
    scanf("%d", &t);
    while (t--)
    {
   
        scanf("%d%d", &n, &v);
        for (int i = 1; i <= n; ++i)
            scanf("%d", &w[i].vi);
        for (int i = 1; i <= n; ++i)
            scanf("%d", &w[i].wi);
        printf("%d\n", ans());
    }
    return 0;
}
如何停止时间:亲吻
如何时间旅行:阅读
如何逃脱时间:音乐
如何感受时间:写作
如何释放时间:呼吸
人生一世便是要抓住生命里的每一分,每一秒,聆听自己内心深处的回响,在分秒中解读生命的奥义
全部评论

相关推荐

断电再接线:1. 简历排版方面,你这内容比较少,一页放完。各模块之间建议用明显的分隔线分开,现在一眼看上去非常乱。教育经历留白太多。项目经历格式不统一。 2. 第一个项目,硬件设计太笼统,硬件架构规划是指板级电路设计还是FPGA逻辑设计?FPGA时序逻辑设计具体指的什么?实现的三个低速协议以及使用协议进行控制时序,是指什么? 3. 第二个项目,我觉得你可以和第一个项目整合一下,合并为一个项目。第二个项目说实话随便买个zynq开发板都有一直petalinux的教程,作为一个独立的项目不合适的,更像是一个小作业。 4. 第三个项目,项目内容这里,其实和环境搭建之类的东西提一嘴就好了,环境准备和编译安装工具链这种东西没多大必要写,实在要写的话可以 说 使用docker 独立sdk环境之类的。你说的这个工具我没用过,我用的比较多的是busybox和buildroot,是基于menuconfig进行配置的,如果scratch也是类似的模式的话,那我觉得这个项目也经不起细推。你可以往内核裁剪那方向靠,我说的这两个工具你也可以看看。 5. 你熟悉这些接口时序的话,你可以进一步去看一下驱动开发,然后面试的时候突出这个作为重点。第三个项目也可以将驱动开发给补充进去。因为单编内核和构建文件系统,其实很多时候是体力劳动。 6. 特长这里,独立成一个荣誉奖项的模块,把你获得的奖学金和竞赛奖项放一起。数模的话,写了国赛,美赛就不用写了。 7. 总的来说可以了,你简历上写的东西你只要都熟悉,找个实习还是没问题的。 8. 嵌入式分为硬件,底层软件和应用软件,看你的经历我建议你往底层靠,多去熟悉常用的通信接口,去看内核和驱动,网络编程这块也可以去了解一下。然后去**刷刷hot100
点赞 评论 收藏
分享
2024-12-04 22:59
已编辑
江苏科技大学 后端
0offer要鼠啦:为啥没写会玩青钢影
点赞 评论 收藏
分享
评论
点赞
收藏
分享
牛客网
牛客企业服务