PAT A1002 for Polynomials

前言

传送门

正文

题目描述

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
K N​1 aN1​​ N2​ aN2… NK aNK

where K is the number of nonzero terms in the polynomial, N​i and aN​i(i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤NK<⋯<N2<N1≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

思路:

对相应指数的项的系数相加即可,a[i]表示指数为i的项的系数

参考题解:

#include<cstdio>
const int max_len=1001;
int main(){
	int k,m,count=0;
	double a[max_len],n;
	memset(a,0,sizeof(a));
	for(int i=0;i<2;i++){
		scanf("%d",&k);
		while(k--){
		scanf("%d%lf",&m,&n);
		a[m]+=n;
		}
	}
	for(int i=0;i<max_len;i++){
		if(a[i]!=0){
			count++;
		}
	} 
	printf("%d",count);
	for(int i=max_len-1;i>=0;i--){
		if(a[i]!=0){
			printf(" %d %.1f",i,a[i]);
		}
	}
	return 0;
}

后记

独揽月下萤火,照亮一纸寂寞;
追忆那些什么,你说的爱我;
花开后花又落 ,轮回也没结果;
苔上雪告诉我, 你没归来过。

《南山忆》——许嵩

全部评论

相关推荐

01-23 14:54
同济大学 Java
热爱敲代码的程序媛:给你提几点【专业技能】这个模块里面可优化的地方:1.【具备JVM调优经验】可以去b站上搜一下JVM调优的视频,估计一两个小时凭你的学习能力就能掌握JVM调优的实践方面的技能。2.【MySql优化】MySql这一栏,你去b站或者找个博客看看MySql优化,学一下,如果你本身比较熟悉MySql语句的话,那基本半天时间凭你的学习能力MySql语句优化方面的技能你也能掌握个差不多。以上1,2两点主要是因为我看你专业技能大部分都说的是偏理论,没有写应用。再就是最后,你结合你的项目,想一想你的项目中哪些sql语句是可以用MySql优化的,到时候你面试的时候也好结合着说一下。
点赞 评论 收藏
分享
评论
点赞
收藏
分享

创作者周榜

更多
牛客网
牛客企业服务