【水】hdu4493

Tutor

   Problem Description
Lilin was a student of Tonghua Normal University. She is studying at University of Chicago now. Besides studying, she worked as a tutor teaching Chinese to Americans. So, she can earn some money per month. At the end of the year, Lilin wants to know his average monthly money to decide whether continue or not. But she is not good at calculation, so she ask for your help. Please write a program to help Lilin to calculate the average money her earned per month.
 

Input
The first line contain one integer T, means the total number of cases. 
Every case will be twelve lines. Each line will contain the money she earned per month. Each number will be positive and displayed to the penny. No dollar sign will be included.
 

Output
The output will be a single number, the average of money she earned for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign without tail zero. There will be no other spaces or characters in the output.
 

Sample Input
2 100.00 489.12 12454.12 1234.10 823.05 109.20 5.27 1542.25 839.18 83.99 1295.01 1.75 100.00 100.00 100.00 100.00 100.00 100.00 100.00 100.00 100.00 100.00 100.00 100.00
 

Sample Output
$1581.42 $100
期末考完了,把之前欠的题解补上!

求平均值,输出的时候要控制格式。

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
long  t;
double sum, a, re;
char s[10000];
int main()
{
    //freopen("1.in","r",stdin);
    //freopen("1.out","w",stdout);

    scanf("%d",&t);
    for (long i=1; i<=t; i++)
    {
        sum = 0;
        for (long j=1; j<=12; j++)
        {
            scanf("%lf",&a);
            sum += a;
            re = sum / 12;
        }
       // printf("%.2f\n",re);
        printf("$");
        sprintf(s, "%.2f", re);
        long l=strlen(s);
        for (long k=0; k<l-3; k++)
        {
            printf("%c",s[k]);
        }
        if ((s[l-1]!='0')||(s[l-2]!='0'))
        {
            printf("%c",s[l-3]);
            printf("%c",s[l-2]);
            if (s[l-1]!='0') printf("%c",s[l-1]);

        }
        cout<<endl;



    }

}




全部评论

相关推荐

一个菜鸡罢了:哥们,感觉你的简历还是有点问题的,我提几点建议,看看能不能提供一点帮助 1. ”新余学院“别加粗,课程不清楚是否有必要写,感觉版面不如拿来写一下做过的事情,教育经历是你的弱势就尽量少写 2. “干部及社团经历”和“自我评价”删掉 3. 论文后面的“录用”和“小修”啥的都删掉,默认全录用,问了再说,反正小修毕业前肯定能发出来 4. 工作经验和研究成果没有体现你的个人贡献,着重包装一下个人贡献
点赞 评论 收藏
分享
想去夏威夷的小哥哥在度假:5和6才是重点
点赞 评论 收藏
分享
点赞 收藏 评论
分享
牛客网
牛客企业服务