【水】poj1003
Description
How far can you make a stack of cards overhang a table? If you have one card, you can create a maximum overhang of half a card length. (We're assuming that the cards must be perpendicular to the table.) With two cards you can make the top card overhang the bottom one by half a card length, and the bottom one overhang the table by a third of a card length, for a total maximum overhang of 1/2 <tt>+</tt> 1/3 <tt>=</tt> 5/6 card lengths. In general you can make n cards overhang by 1/2 <tt>+</tt> 1/3 <tt>+</tt> 1/4 <tt>+</tt> ... <tt>+</tt> 1/(n <tt>+</tt> 1) card lengths, where the top card overhangs the second by 1/2, the second overhangs tha third by 1/3, the third overhangs the fourth by 1/4, etc., and the bottom card overhangs the table by 1/(n <tt>+</tt> 1). This is illustrated in the figure below.
Input
Output
Sample Input
1.00 3.71 0.04 5.19 0.00
Sample Output
3 card(s) 61 card(s) 1 card(s) 273 card(s)
太水了,不想多说了
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
double x;
int main()
{
// freopen("1003.in", "r", stdin);
while((scanf("%lf", &x) != EOF)&&(x != (double)0))
{
double tmp = 0;
long i;
for (i = 2; tmp < x; i++)
{
tmp += (1.0 / i);
}
printf("%d ", i - 2);
printf("card(s)\n");
}
return 0;
}