【堆】poj2833

The Average

Description

In a speech contest, when a contestant finishes his speech, the judges will then grade his performance. The staff remove the highest grade and the lowest grade and compute the average of the rest as the contestant’s final grade. This is an easy problem because usually there are only several judges.

Let’s consider a generalized form of the problem above. Given n positive integers, remove the greatest n1 ones and the least n2 ones, and compute the average of the rest.

Input

The input consists of several test cases. Each test case consists two lines. The first line contains three integers n1n2 and n (1 ≤ n1n2 ≤ 10, n1 + n2 < n ≤ 5,000,000) separate by a single space. The second line contains npositive integers ai (1 ≤ ai ≤ 108 for all i s.t. 1 ≤ i ≤ n) separated by a single space. The last test case is followed by three zeroes.

Output

For each test case, output the average rounded to six digits after decimal point in a separate line.

Sample Input

1 2 5
1 2 3 4 5
4 2 10
2121187 902 485 531 843 582 652 926 220 155
0 0 0

Sample Output

3.500000
562.500000


大意:给出N个分数,要求去掉n1个最高分,n2个最低分,然后算平均分。

看数据范围明显直接排序是不行的,可以先求总和,同时用一个大根堆和一个小根堆记录下n1个最高分和n2个最低分

总和减去n1个最高分,n2个最低分的和,除以数据个数即可。


#include<iostream>
#include<cstring>
#include<cstdio>
#include<queue>
#include<algorithm>
using namespace std;

long n, n1, n2;
priority_queue <long, vector<long>, greater<long> > q1;  //大根堆
priority_queue <long> q2;


int main()
{
    freopen("poj2833.in", "r", stdin);
    scanf("%ld%ld%ld", &n1, &n2, &n);
    while ((n1 != 0) && (n2 != 0) && (n != 0))
    {

        long long sum = 0;
        for (long i = 1; i <= n; i++)
        {
            long t;
            scanf("%d", &t);
            sum += t;
            q1.push(t);
            q2.push(t);
            if (q1.size() > n1) q1.pop();
            if (q2.size() > n2) q2.pop();
        }
        while (!q1.empty())
        {
            sum -= q1.top();
            q1.pop();
        }
        while (!q2.empty())
        {
            sum -= q2.top();
            q2.pop();
        }
        double ave = (1.0 * sum) / (n - n1 - n2);
        printf("%.6lf\n", ave);
        scanf("%ld%ld%ld", &n1, &n2, &n);
    }
    return 0;
}


全部评论

相关推荐

2024-12-27 23:45
已编辑
三江学院 Java
程序员牛肉:死局。学历+无实习+项目比较简单一点。基本就代表失业了。 尤其是项目,功能点实在是太假了。而且提问点也很少。第一个项目中的使用jwt和threadlocal也可以作为亮点写出来嘛?第二个项目中的“后端使用restful风格”,“前端采用vue.JS”,“使用redis”也可以作为亮点嘛? 项目实在是太简单了,基本就是1+1=2的水平。而你目标投递的肯定也是小厂,可小厂哪里有什么培养制度,由于成本的问题,人家更希望你来能直接干活,所以你投小厂也很难投。基本就是死局,也不一定非要走后端这条路。可以再学一学后端之后走测试或者前端。 除此之外,不要相信任何付费改简历的。你这份简历没有改的必要了,先沉淀沉淀
点赞 评论 收藏
分享
评论
点赞
收藏
分享

创作者周榜

更多
牛客网
牛客企业服务