【SPFA】poj1511

Invitation Cards

Description

In the age of television, not many people attend theater performances. Antique Comedians of Malidinesia are aware of this fact. They want to propagate theater and, most of all, Antique Comedies. They have printed invitation cards with all the necessary information and with the programme. A lot of students were hired to distribute these invitations among the people. Each student volunteer has assigned exactly one bus stop and he or she stays there the whole day and gives invitation to people travelling by bus. A special course was taken where students learned how to influence people and what is the difference between influencing and robbery. 

The transport system is very special: all lines are unidirectional and connect exactly two stops. Buses leave the originating stop with passangers each half an hour. After reaching the destination stop they return empty to the originating stop, where they wait until the next full half an hour, e.g. X:00 or X:30, where 'X' denotes the hour. The fee for transport between two stops is given by special tables and is payable on the spot. The lines are planned in such a way, that each round trip (i.e. a journey starting and finishing at the same stop) passes through a Central Checkpoint Stop (CCS) where each passenger has to pass a thorough check including body scan. 

All the ACM student members leave the CCS each morning. Each volunteer is to move to one predetermined stop to invite passengers. There are as many volunteers as stops. At the end of the day, all students travel back to CCS. You are to write a computer program that helps ACM to minimize the amount of money to pay every day for the transport of their employees. 

Input

The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case begins with a line containing exactly two integers P and Q, 1 <= P,Q <= 1000000. P is the number of stops including CCS and Q the number of bus lines. Then there are Q lines, each describing one bus line. Each of the lines contains exactly three numbers - the originating stop, the destination stop and the price. The CCS is designated by number 1. Prices are positive integers the sum of which is smaller than 1000000000. You can also assume it is always possible to get from any stop to any other stop.

Output

For each case, print one line containing the minimum amount of money to be paid each day by ACM for the travel costs of its volunteers.

Sample Input

2
2 2
1 2 13
2 1 33
4 6
1 2 10
2 1 60
1 3 20
3 4 10
2 4 5
4 1 50

Sample Output

46
210
大意:求源点到每个点的距离和加上每个点到原点的距离和
思路,先正向一次SPFA再讲图反转进行一次SPFA
WA了三次,然后就看了一下discuss发现要用longlong才行……
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;;
const long N = 1000010, M = 1000010;
const long INF = 1073741824;
struct ty
{
    long t, w, next;
};
long tt, n, t, m;
long long sum;
long head1[N], head2[N];
ty edge1[M], edge2[M];
long q[1000000];
bool v[N];
long dist[N];
void insertedge1(long x, long y, long z, long k)
{
    edge1[k].t = y;
    edge1[k].w = z;
    edge1[k].next = head1[x];
    head1[x] = k;
}
void insertedge2(long x, long y, long z, long k)
{
    edge2[k].t = y;
    edge2[k].w = z;
    edge2[k].next = head2[x];
    head2[x] = k;
}
void init()
{
    memset(head1, 0, sizeof(head1));
    memset(edge1, 0, sizeof(edge1));
    memset(head2, 0, sizeof(head2));
    memset(edge2, 0, sizeof(edge2));
    m = 0;
    sum = 0;
    for (long i = 1; i <= t; i++)
    {
        long x, y, z;
        scanf("%d%d%d", &x, &y, &z);
        insertedge1(x, y, z, ++m);
        insertedge2(y, x, z, m);
    }
}
void spfa1()
{
    memset(v, 0, sizeof(v));
    memset(dist, 127, sizeof(dist));
    long l = 0, r = 0;
    q[r++] = 1;
    v[1] = true;
    dist[1] = 0;
    while (l < r)
    {
        long x = q[l++];
        v[x] = false;
        for (long i = head1[x]; i != 0; i = edge1[i].next)
        {
            long t = edge1[i].t;
            if (dist[t] > dist[x] + edge1[i].w)
            {
                dist[t] = dist[x] + edge1[i].w;
                if (!v[t])
                {
                    q[r++] = t;
                    v[t] = true;
                }
            }
        }
    }

    for (long i = 2; i <= n; i++)
    {
        sum += dist[i];
      
    }

}

void spfa2()
{
    memset(v, 0, sizeof(v));
    memset(dist, 127, sizeof(dist));
    long l = 0, r = 0;
    q[r++] = 1;
    v[1] = true;
    dist[1] = 0;
    while (l < r)
    {
        long x = q[l++];
        v[x] = false;
        for (long i = head2[x]; i != 0; i = edge2[i].next)
        {
            long t = edge2[i].t;
            if (dist[t] > dist[x] + edge2[i].w)
            {
                dist[t] = dist[x] + edge2[i].w;
                if (!v[t])
                {
                    q[r++] = t;
                    v[t] = true;
                }
            }
        }
    }

    for (long i = 2; i <= n; i++)
        sum += dist[i];

}
int main()
{
    freopen("poj1511.in", "r", stdin);
    scanf("%d", &tt);
    for (long i = 1; i <= tt; i++)
    {
        scanf("%d%d", &n, &t);
        init();
        spfa1();
        spfa2();
        cout << sum << endl;
    }
    return 0 ;
}


全部评论

相关推荐

工作基本定了,比较满意。这深度学习真是难搞啊,论文看不懂,代码看不懂,不会改,创新点???&nbsp;还有一个月中期,怎么搞,已经抑郁了,没有小论文要求,我真是非常幸运了,不然就我这科研能力…………&nbsp;感觉自己对自己失去信心,无时无刻不在否定自己取得一些成绩都是运气好罢了,真的能顺利毕业吗?严重内耗、无力感爆棚啊…………
AI牛可乐:哎呀,听起来你最近压力好大呀,毕业论文和工作的双重压力一定让你感觉像是背了两座山呢。深度学习确实挺复杂的,就像是要在一片迷雾中找到出路一样。但是,你已经很棒了,工作都定好了,这是很大的成就呢! 论文的事情,别太担心。每个人都有看不懂代码和论文的时候,这是正常的。至于创新点嘛,有时候灵感就像小猫一样,需要一点一点地哄出来的。你可以先试试把你看过的资料整理一下,说不定就能找到新的思路呢。 中期答辩前,你可以列个计划,一步一步来,把大问题分解成小问题,一点一点克服。记得,你不是一个人在战斗,你的导师、同学都是你的战友哦。 至于信心嘛,别否定自己,每个人都会有低谷的时候。你已经取得的成绩,都是你实力的体现。毕业不是问题,只要你不放弃,就一定能顺利走过去的。加油哦,我相信你可以的! 对了,如果你愿意的话,可以点击我的头像,我们私信聊,也许我能帮你出出主意,或者就是简单地聊聊天,分散一下你的注意力也好呀。🐮💪🌟
点赞 评论 收藏
分享
ProMonkey2024:5个oc?厉害! 但是有一个小问题:谁问你了?😡我的意思是,谁在意?我告诉你,根本没人问你,在我们之中0人问了你,我把所有问你的人都请来 party 了,到场人数是0个人,誰问你了?WHO ASKED?谁问汝矣?誰があなたに聞きましたか?누가 물어봤어?我爬上了珠穆朗玛峰也没找到谁问你了,我刚刚潜入了世界上最大的射电望远镜也没开到那个问你的人的盒,在找到谁问你之前我连癌症的解药都发明了出来,我开了最大距离渲染也没找到谁问你了我活在这个被辐射蹂躏了多年的破碎世界的坟墓里目睹全球核战争把人类文明毁灭也没见到谁问你了(别的帖子偷来的,现学现卖😋)
点赞 评论 收藏
分享
评论
点赞
收藏
分享
牛客网
牛客企业服务