【floyd】poj3660
Description
N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.
The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ N; A ≠ B), then cow A will always beat cow B.
Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.
Input
* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B
Output
* Line 1: A single integer representing the number of cows whose ranks can be determined
Sample Input
5 5 4 3 4 2 3 2 1 2 2 5
Sample Output
2
给出一些牛之间的胜负关系,问能够确定名次的牛有多少
怎么能够确定一头牛的排名?如果他之前的和他之后牛的数量和为n-1 则它的排名就确定了
于是一次floyd就可以了……
后来看网上的题解才知道这是传说中的传递闭包
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
long n, m;
long f[200][200];
int main()
{
freopen("poj3660.in", "r", stdin);
while (scanf("%d%d", &n, &m) != EOF)
{
memset(f, sizeof(f), 0);
for (long i = 1; i <= m; i++)
{
long x, y;
scanf("%d%d", &x, &y);
f[x][y] = 1;
}
for (long k = 1; k <= n; k++)
for (long i = 1; i <= n; i++)
for (long j = 1; j <= n; j++)
if (f[i][k] + f[k][j] == 2) f[i][j] = 1;
long sum = 0;
for (long i = 1; i <= n; i++)
{
long cnt = 0;
for (long j = 1; j <= n; j++)
if (f[i][j] + f[j][i] >= 1) cnt++;
if (cnt == n - 1) sum++;
}
printf ("%d\n", sum);
}
return 0;
}