Catch That Cow

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
Teleporting: FJ can move from any point X to the point 2 × X in a single minute.
If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K
Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input

5 17
Sample Output

4
Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

/*广度优先遍历*/
#include<stdio.h>
#include<string.h>
int k;
int vis[10000];
typedef struct node
{
    int pos;
    int step;
}node;
node cow[10005];
int bfs(int n)
{    
    node temp;
    int head=0,rear=0;
    vis[n]=1;
    cow[rear].pos=n;
    cow[rear++].step=0;
    while(head<rear)
    {    
        temp=cow[head++];
        if( temp.pos>=0 && temp.pos+1<= 100000 && !vis[temp.pos+1]){
            cow[rear].pos = temp.pos + 1;               
            cow[rear++].step = temp.step + 1;
            vis[temp.step+1] = 1;                             
            if( temp.pos + 1 == k) return temp.step + 1;    
        }
        if( temp.pos>0 && temp.pos-1<=100000 && !vis[temp.pos-1]){
            cow[rear].pos = temp.pos - 1;               
            cow[rear++].step = temp.step + 1;
            vis[temp.step+1] = 1;                             
            if( temp.pos - 1 == k) return temp.step + 1;    
        }
        if( temp.pos>0 && temp.pos*2<= 100000 && !vis[temp.pos*2]){
            cow[rear].pos = temp.pos *2;               
            cow[rear++].step = temp.step + 1;
            vis[temp.step+1] = 1;                             
            if( temp.pos *2 == k) return temp.step + 1;    
        }        
    }


}
int main()
{

    int n;
    while(scanf("%d%d",&n,&k)!=EOF)
    {
        memset(vis,0,sizeof(vis));
        if(k<=n) printf("%d\n",n-k);
        else printf("%d\n",bfs(n));
    }
    return 0;    
}
全部评论

相关推荐

冲芭芭拉鸭:你这图还挺新,偷了。
投递美团等公司10个岗位
点赞 评论 收藏
分享
点赞 收藏 评论
分享
牛客网
牛客企业服务