poj1328(Radar Installation)
Description
Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.
We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.
Figure A Sample Input of Radar Installations
We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.
Figure A Sample Input of Radar Installations
Input
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.
The input is terminated by a line containing pair of zeros
The input is terminated by a line containing pair of zeros
Output
For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.
Sample Input
3 2 1 2 -3 1 2 1 1 2 0 2 0 0
Sample Output
Case 1: 2 Case 2: 1
区间选点问题,贪心策略,对右端点从小到大排序,相同时左端点从大到小排列。优先选取前面的区间右端点,如无法覆盖下一个区间,则选取下一个右端点。
#include <iostream>
#include <sstream>
#include <fstream>
#include <string>
#include <map>
#include <vector>
#include <list>
#include <set>
#include <stack>
#include <queue>
#include <deque>
#include <algorithm>
#include <functional>
#include <iomanip>
#include <limits>
#include <new>
#include <utility>
#include <iterator>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cctype>
#include <cmath>
#include <ctime>
using namespace std;
const int inf = 0x3f3f3f3f;
const double pi = acos(-1.0);
const double eps = 1e-8;
int dx[] = {0, 1, 0, -1}, dy[] = {-1, 0, 1, 0};
const int maxn = 25010;
struct island
{
double left, right;
bool operator < (const island& b) const
{
if (right != b.right)
return right < b.right;
return left > b.left;
}
};
int main()
{
int n, d, kase = 1;
while (scanf("%d%d", &n, &d) == 2 && (n || d))
{
island s[1010];
int can = 1;
for (int i = 0; i < n; ++i)
{
int x, y;
scanf("%d%d", &x, &y);
if (abs(y) > d)
{
can = 0;
continue;
}
s[i].left = x - sqrt(1.0*d*d-y*y);
s[i].right = x + sqrt(1.0*d*d-y*y);
}
if (!can)
{
printf("Case %d: -1\n", kase++);
continue;
}
sort(s, s+n);
int ans = 1;
island tmp = s[0];
for (int i = 1; i < n; ++i)
if (s[i].left > tmp.right)
{
++ans;
tmp = s[i];
}
printf("Case %d: %d\n", kase++, ans);
}
return 0;
}
算法码上来 文章被收录于专栏
公众号「算法码上来」。godweiyang带你学习算法,不管是编程算法,还是深度学习、自然语言处理算法都一网打尽,更有各种计算机新鲜知识和你分享。别急,算法码上来。