A1094(The Largest Generation)
A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.
Input Specification:
Each input file contains one test case. Each case starts with two positive integers N (<100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (<N) which is the number of family members who have children. Then M lines follow, each contains the information of a family member in the following format:
ID K ID[1] ID[2] … ID[K]
where ID is a two-digit number representing a family member, K (>0) is the number of his/her children, followed by a sequence of two-digit ID’s of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.
Sample Input:
23 13
21 1 23
01 4 03 02 04 05
03 3 06 07 08
06 2 12 13
13 1 21
08 2 15 16
02 2 09 10
11 2 19 20
17 1 22
05 1 11
07 1 14
09 1 17
10 1 18
Sample Output:
9 4
//The Largest Generation
//多叉树的遍历
#include <iostream>
#include <cstdio>
#include <vector>
#include <queue>
using namespace std;
//结点结构体
struct Node
{
string ID; //编号
int childNum; //孩子的数目
vector<Node> Children;
};
void count(vector<Node> v)
{
//层序遍历多叉数
vector<int> level;
int maxCount = 1;
int t = 0;
queue<Node> Q;
Q.push(v[1]); //root push
t++;
while (!Q.empty())
{
int size = Q.size();
Node head = Q.front();
for (int i = 0; i < head.childNum; ++i)
{
//输入子代
string id = head.Children[i].ID;
int temp = id[0] == '0' ? id[1] - '0' : atoi(id.c_str());
Q.push(v[temp]);
}
Q.pop();
t--;
if (t == 0)
{
maxCount = max(size, maxCount);
level.push_back(maxCount);
t = size;
}
}
cout << maxCount << " ";
for (t = 0; t < level.size(); ++t)
{
if (level[t] == maxCount)
break;
}
cout << ++t;
}
int main(int argc, char const *argv[])
{
/* code */
int nodes = 0;
int row = 0;
scanf("%d%d", &nodes, &row);
vector<Node> arr(nodes + 1);
for (int i = 1; i <= 23; ++i)
{
arr[i].ID = (i < 10) ? "0" + to_string(i) : to_string(i);
}
string in;
int n;
for (int i = 0; i < row; ++i)
{
cin >> in;
int p = in[0] == '0' ? in[1] - '0' : atoi(in.c_str());
cin >> n;
for (int j = 0; j < n; ++j)
{
cin >> in;
Node son;
son.ID = in;
arr[p].Children.push_back(son);
}
arr[p].childNum = arr[p].Children.size();
}
count(arr);
return 0;
}