06-图2 Saving James Bond - Easy Version (25 分)

This time let us consider the situation in the movie “Live and Let Die” in which James Bond, the world’s most famous spy, was captured by a group of drug dealers. He was sent to a small piece of land at the center of a lake filled with crocodiles. There he performed the most daring action to escape – he jumped onto the head of the nearest crocodile! Before the animal realized what was happening, James jumped again onto the next big head… Finally he reached the bank before the last crocodile could bite him (actually the stunt man was caught by the big mouth and barely escaped with his extra thick boot).

Assume that the lake is a 100 by 100 square one. Assume that the center of the lake is at (0,0) and the northeast corner at (50,50). The central island is a disk centered at (0,0) with the diameter of 15. A number of crocodiles are in the lake at various positions. Given the coordinates of each crocodile and the distance that James could jump, you must tell him whether or not he can escape.

Input Specification:

Each input file contains one test case. Each case starts with a line containing two positive integers N (≤100), the number of crocodiles, and D, the maximum distance that James could jump. Then N lines follow, each containing the (x,y) location of a crocodile. Note that no two crocodiles are staying at the same position.

Output Specification:

For each test case, print in a line “Yes” if James can escape, or “No” if not.

Sample Input 1:

14 20
25 -15
-25 28
8 49
29 15
-35 -2
5 28
27 -29
-8 -28
-20 -35
-25 -20
-13 29
-30 15
-35 40
12 12

Sample Output 1:

Yes

Sample Input 2:

4 13
-12 12
12 12
-12 -12
12 -12

Sample Output 2:

No

Code

#include <stdio.h>
#include <stdlib.h>
#include <math.h>
#define MaxVertexNum 100

typedef struct VNode *PtrToVertex;
typedef int Vertexs;
struct VNode{
    double X;
    double Y;
}VertexsNode[MaxVertexNum];
int N,Visited[MaxVertexNum];
double D;

void CreatGraph();
int IsJump(Vertexs V,Vertexs W);
int DFS(Vertexs V);
int IsSafe(Vertexs V);

int main()
{
    scanf("%d %lf",&N,&D);
    CreatGraph();
    Vertexs V;
    int answer;
    for(V=0;V<=N;V++) Visited[V] = 0;
    answer = DFS(0);
// for(V=0;V<=N;V++) printf("%d ",Visited[V]);
// printf("\n");
    if(answer) printf("Yes\n");
    else printf("No\n");
    return 0;
}

void CreatGraph()
{
    VertexsNode[0].X = 0;
    VertexsNode[0].Y = 0;
    Vertexs V;
    for(V=1;V<=N;V++)
    {
        scanf("%lf %lf",&VertexsNode[V].X,&VertexsNode[V].Y);
// printf("VertexsNode[%d].X = %lf,VertexsNode[%d].Y = %lf\n",V,VertexsNode[V].X,V,VertexsNode[V].Y);
    }
}

int IsJump(Vertexs V,Vertexs W)
{
    int flag = 1;
    double distance = pow(VertexsNode[V].X-VertexsNode[W].X,2.0) + pow(VertexsNode[V].Y-VertexsNode[W].Y,2.0);
    if(V==0)
    {
        if(distance>pow(D+15.0/2,2)) flag = 0;
    }else{
        if(distance>pow(D,2)) flag = 0;
    }
    return flag;
}

int DFS(Vertexs V)
{
    Vertexs W;
    int answer =0;
    Visited[V] = 1;
    if(IsSafe(V)) answer = 1;
    else{
        for(W=1;W<=N;W++)
        {
            if(!Visited[W]&&IsJump(V,W))
            {
                answer = DFS(W);
                if(answer) break;
            }
        }
    }
    return answer;
}

int IsSafe(Vertexs V)
{
    int flag = 0;
    if((50-fabs(VertexsNode[V].X)<=D) || (50-fabs(VertexsNode[V].Y)<=D)) flag = 1;
    return flag;
}
全部评论

相关推荐

点赞 评论 收藏
分享
喜欢走神的孤勇者练习时长两年半:池是池,发是发,我曾池,我现黑
点赞 评论 收藏
分享
手撕没做出来是不是一定挂
Chrispp3:不会,写出来也不一定过
点赞 评论 收藏
分享
评论
点赞
收藏
分享
牛客网
牛客企业服务