1031 Hello World for U (20 分)(PAT)(C语言)

Given any string of N (≥5) characters, you are asked to form the characters into the shape of U. For example, helloworld can be printed as:

h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n​1 characters, then left to right along the bottom line with n​2​​ characters, and finally bottom-up along the vertical line with n​3​​ characters. And more, we would like U to be as squared as possible – that is, it must be satisfied that n​1​​ =n​3​​ =max { k | k≤n​2​​ for all 3≤n​2​​ ≤N } with n​1​​ +n​2​​ +n​3​​ −2=N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!

Sample Output:

h   !
e   d
l   l
lowor

算法&程序

#include <stdio.h>
#include <string.h>
#define Max 81
int main()
{
    char str[Max];
    gets(str);
    int len = strlen(str);
    int n1, n2, n3, i;
    n1 = n3 = (len+2)/3;
    n2 = (len+2)/3 + (len+2)%3;
    for(i=0; i<n1-1; i++){
        printf("%c",str[i]);
        for(int j=0; j<n2-2; j++) printf(" ");
        printf("%c\n",str[len-1-i]);
    }
    for(; i<n1+n2-1; i++) printf("%c",str[i]);
    printf("\n");
    return 0;
}
全部评论

相关推荐

kyw_:接好运
点赞 评论 收藏
分享
10-06 12:46
门头沟学院 Java
跨考小白:定时任务启动
点赞 评论 收藏
分享
11-30 11:07
河南大学 Java
宇宙厂 测开 n*15
丘丘给个offer:有后选后
点赞 评论 收藏
分享
评论
点赞
收藏
分享
牛客网
牛客企业服务