PAT(排序)——1028. List Sorting (25)

1028. List Sorting (25)

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input

Each input file contains one test case. For each case, the first line contains two integers N (<=100000) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student’s record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID’s; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID’s in increasing order.

Sample Input 1

3 1
000007 James 85
000010 Amy 90
000001 Zoe 60

Sample Output 1

000001 Zoe 60
000007 James 85
000010 Amy 90

Sample Input 2

4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98

Sample Output 2

000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60

Sample Input 3

4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90

Sample Output 3

000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90

题目大意:

按字段排序。

题目解析:

结构体+qsort排序。

具体代码:

#include<iostream>
#include<cstdlib>
#include<algorithm>
#include<cstring>
using namespace std;
struct node{
	int id;
	char name[10];
	int score;
}A[100010];
int flag;
int cmp(const void* x,const void* y){
	node a=*(node*)x,b=*(node*)y; 
	if(flag==1){
		return a.id-b.id;
	}else if(flag==2){
		if(strcmp(a.name,b.name))
			return strcmp(a.name,b.name);
		else
			return a.id-b.id; 
	}else{
		if(a.score!=b.score)
			return a.score-b.score;
		else
			return a.id-b.id; 
	}
}
int main()
{
    int n;
    cin>>n>>flag;
    for(int i=0;i<n;i++)
    	scanf("%d %s %d",&A[i].id,&A[i].name,&A[i].score);
    qsort(A,n,sizeof(A[0]),cmp);
    for(int i=0;i<n;i++)
    	printf("%06d %s %d\n",A[i].id,A[i].name,A[i].score);
    return 0;
}
全部评论

相关推荐

神哥了不得:你简历字体有点不太协调呀,下面的字实在太小了呀,而且项目也不太行,建议换几个高质量的项目,面试会多很多
点赞 评论 收藏
分享
02-05 08:49
已编辑
武汉大学 Web前端
野猪不是猪🐗:36k和36k之间亦有差距,ms的36k和pdd的36k不是一个概念
点赞 评论 收藏
分享
评论
点赞
收藏
分享

创作者周榜

更多
牛客网
牛客企业服务