PAT(树)——1094 The Largest Generation (25 分)

1094 The Largest Generation (25 分)
A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.

Input Specification:
Each input file contains one test case. Each case starts with two positive integers N (<100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (<N) which is the number of family members who have children. Then M lines follow, each contains the information of a family member in the following format:

ID K ID[1] ID[2] … ID[K]
where ID is a two-digit number representing a family member, K (>0) is the number of his/her children, followed by a sequence of two-digit ID’s of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.

Sample Input:
23 13
21 1 23
01 4 03 02 04 05
03 3 06 07 08
06 2 12 13
13 1 21
08 2 15 16
02 2 09 10
11 2 19 20
17 1 22
05 1 11
07 1 14
09 1 17
10 1 18
Sample Output:
9 4

题目大意:

给出家庭结构树,求哪一代人数最多。

题目解析:

结构体保存孩子数组和级别,dfs遍历。

具体代码:

#include<iostream>
#include<algorithm>
#include<cmath>
#include<vector>
using namespace std;
bool isC[110]={false};
struct node{
	int level;
	vector<int> child;
}A[110];
void dfs(int root){
	for(int i=0;i<A[root].child.size();i++){
		int child=A[root].child[i];
		A[child].level=A[root].level+1;
		dfs(child);
	}
}
int main()
{
    freopen("data.in","r",stdin);
    int n,m,root;
    scanf("%d %d",&n,&m);
    for(int i=0;i<m;i++){
    	int parent,k;
    	scanf("%d",&parent);
    	scanf("%d",&k);
    	for(int j=0;j<k;j++){
    		int child;
    		scanf("%d",&child);
    		isC[child]=true;
    		A[parent].child.push_back(child);
		}
	}
	root=1;
	A[root].level=1;
	dfs(root);
	int maxlevel=1,maxnum=1;
	for(int i=1;i<n;i++){
		int num=0;
		for(int j=1;j<=n;j++){
			if(A[j].level==i){
				num++;
				if(num>maxnum){
					maxnum=num;
					maxlevel=i;
				}
			}
		}
	}
	printf("%d %d",maxnum,maxlevel);
    return 0;
}
全部评论

相关推荐

小覃1:硕士了还投助理岗位吗,一般不都直接干工程师了吗
点赞 评论 收藏
分享
02-22 20:28
重庆大学 Java
程序员牛肉:首先不要焦虑,你肯定是有希望的。 首先我觉得你得好好想一想自己想要什么。找不到开发岗就一定是失败的吗?那开发岗的35岁危机怎么说?因此无论是找工作还是考公我觉得你都需要慎重的想一想。但你一定要避开这样一个误区:“我是因为找不到工作所以不得不选择考公”。 千万不要这么想。你这个学历挺好的了,因此你投后端岗肯定是有面试机会的。有多少人简历写的再牛逼,直接连机筛简历都过不去有啥用?因此你先保持自信一点。 以你现在的水平的话,其实如果想要找到暑期实习就两个月:一个月做项目+深挖,并且不断的背八股。只要自己辛苦一点,五月份之前肯定是可以找到暑期实习的,你有点太过于高看大家之间的技术差距了。不要焦虑不要焦虑。 除此之外说回你这个简历内容的话,基本可以全丢了。如果想做后端,先踏踏实实做两个项目再说+背八股再说。如果想考公,那就直接备战考公。 但是但是就像我前面说的:你考公的理由可以是因为想追求稳定,想追求轻松。但唯独不能是因为觉得自己找不到工作。不能这么小瞧自己和自己的学历。
点赞 评论 收藏
分享
球球offer到我邮箱吧:同测评了一个月 亏我笔试还AK了
投递米哈游等公司10个岗位 > 米哈游求职进展汇总
点赞 评论 收藏
分享
评论
点赞
收藏
分享

创作者周榜

更多
牛客网
牛客企业服务