PAT(树)——1102 Invert a Binary Tree (25 分)
1102 Invert a Binary Tree (25 分)
The following is from Max Howell @twitter:
Google: 90% of our engineers use the software you wrote (Homebrew), but you can’t invert a binary tree on a whiteboard so *** off.
Now it’s your turn to prove that YOU CAN invert a binary tree!
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree – and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node from 0 to N−1, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.
Output Specification:
For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.
Sample Input:
8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6
Sample Output:
3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1
题目大意:
给出一棵反转二叉树分别求它的层序遍历和中序遍历序列。
题目解析:
注意数据读入时前面一个是右孩子,后面是左孩子,没有直接给出根节点,只需要记录所有的孩子节点,根节点不是任何结点的孩子。
具体代码:
#include<iostream>
#include<algorithm>
#include<queue>
#include<vector>
using namespace std;
#define N 15
struct node{
int lchild=-1,rchild=-1;
}A[N];
bool isC[N]={false};
vector<int> v;
void levelorder(int root){
queue<int> q;
q.push(root);
while(q.size()!=0){
int t=q.front();q.pop();
v.push_back(t);
if(A[t].lchild!=-1)
q.push(A[t].lchild);
if(A[t].rchild!=-1)
q.push(A[t].rchild);
}
}
void inorder(int root){
if(root==-1)
return;
inorder(A[root].lchild);
v.push_back(root);
inorder(A[root].rchild);
}
void print(){
for(int i=0;i<v.size();i++){
cout<<v[i];
if(i!=v.size()-1)
cout<<" ";
}
}
int main()
{
int n;
cin>>n;
for(int i=0;i<n;i++){
char rchild,lchild;
getchar();
scanf("%c %c",&rchild,&lchild);
if(rchild!='-'){
A[i].rchild=(int)(rchild-'0');
isC[(int)(rchild-'0')]=true;
}
if(lchild!='-'){
A[i].lchild=(int)(lchild-'0');
isC[(int)(lchild-'0')]=true;
}
}
int root=-1;
for(int i=0;i<n;i++)
if(isC[i]==false)
root=i;
levelorder(root);
print();
cout<<endl;
v.clear();
inorder(root);
print();
return 0;
}