PAT(图)——1076. Forwards on Weibo (30)

Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L levels of indirect followers are counted.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=1000), the number of users; and L (<=6), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered from 1 to N. Then N lines follow, each in the format:

M[i] user_list[i]

where M[i] (<=100) is the total number of people that user[i] follows; and user_list[i] is a list of the M[i] users that are followed by user[i]. It is guaranteed that no one can follow oneself. All the numbers are separated by a space.

Then finally a positive K is given, followed by K UserID’s for query.

Output Specification:

For each UserID, you are supposed to print in one line the maximum potential amount of forwards this user can triger, assuming that everyone who can view the initial post will forward it once, and that only L levels of indirect followers are counted.

Sample Input:
7 3
3 2 3 4
0
2 5 6
2 3 1
2 3 4
1 4
1 5
2 2 6
Sample Output:
4
5

题目大意:

给出层级L,发出去的微博会被多少人转发。

题目解析:

简单的BFS计数。

具体代码:

#include<iostream>
#include<algorithm>
#include<vector>
#include<queue>
using namespace std;
#define MAXN 1005
vector<int> F[MAXN];
bool vis[MAXN];
int n,level,sum;
struct node{
	int id;
	int level;
};
void bfs(int now) {
	sum=-1;
	queue<node> q;
	q.push({now,0});
	while(!q.empty()){
		node t=q.front();q.pop();
		if(t.level<=level&&vis[t.id]==false){
			sum++;
			vis[t.id]=true;
			for(int i=0;i<F[t.id].size();i++)
			q.push({F[t.id][i],t.level+1});
		}
	}
}
int main() {
	scanf("%d%d",&n,&level);
	for(int i=1; i<=n; i++) {
		int num;
		scanf("%d",&num);
		for(int j=1; j<=num; j++) {
			int p;
			scanf("%d",&p);
			F[p].push_back(i);
		}
	}
	int k;
	scanf("%d",&k);
	for(int i=1; i<=k; i++) {
		int q;
		scanf("%d",&q);
		fill(vis,vis+MAXN,false);
		bfs(q);
		printf("%d\n",sum);
	}
	return 0;
}
全部评论

相关推荐

牛客963010790号:为什么还要收藏
点赞 评论 收藏
分享
牛客717484937号:双飞硕没实习挺要命的
点赞 评论 收藏
分享
点赞 收藏 评论
分享
牛客网
牛客企业服务