PAT(散列)——1084. Broken Keyboard (20)

On a broken keyboard, some of the keys are worn out. So when you type some sentences, the characters corresponding to those keys will not appear on screen.

Now given a string that you are supposed to type, and the string that you actually type out, please list those keys which are for sure worn out.

Input Specification:

Each input file contains one test case. For each case, the 1st line contains the original string, and the 2nd line contains the typed-out string. Each string contains no more than 80 characters which are either English letters [A-Z] (case insensitive), digital numbers [0-9], or “_” (representing the space). It is guaranteed that both strings are non-empty.

Output Specification:

For each test case, print in one line the keys that are worn out, in the order of being detected. The English letters must be capitalized. Each worn out key must be printed once only. It is guaranteed that there is at least one worn out key.

Sample Input:
7_This_is_a_test
hssaes
Sample Output:
7TI

题目大意:

签到题。

题目解析:

具体代码:

#include<iostream>
#include<map>
#include<ctype.h>
using namespace std;
map<char,int> m;
map<char,int> temp;

int main() {
	string s1,s2;
	cin>>s1>>s2;
	for(int i=0;i<s2.size();i++){
		if(s2[i]>='a'&&s2[i]<='z')
			s2[i]=toupper(s2[i]);
		m[s2[i]]=1;
	}
	for(int i=0;i<s1.size();i++){
		if(s1[i]>='a'&&s1[i]<='z')
			s1[i]=toupper(s1[i]);
		if(m.find(s1[i])==m.end()&&temp.find(s1[i])==temp.end()){
			printf("%c",s1[i]);
			temp[s1[i]]=1;
		}
	}
	return 0;
}
全部评论

相关推荐

不懂!!!:感觉你的项目描述太简单了,建议使用star描述法优化提炼一下,就是使用什么技术或方案解决了什么问题,有什么效果或成果,例如:对axios进行了二次封装,实现了请求的统一管理、错误的集中处理以及接口调用的简化,显著提高了开发效率和代码维护性,使用canvas技术实现了路线绘制功能,通过定义路径绘制函数和动态更新机制,满足了简化的导航可视化需求,提升了用户体验。像什么是使用其他组件库,基本功能描述就最好不要写到项目成果里面去了,加油
点赞 评论 收藏
分享
评论
点赞
收藏
分享

创作者周榜

更多
牛客网
牛客企业服务