PAT(stl)——1039. Course List for Student (25)

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=40000), the number of students who look for their course lists, and K (<=2500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students Ni (<= 200) are given in a line. Then in the next line, Ni student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student’s name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

Sample Input:
11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9
Sample Output:
ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0

题目大意:

给出每门课学生名单,然后输出每位学生的课程序列。

题目解析:

先用string,发现超时,然后看到别人的另外一种方法,因为学生的名字都是固定格式AAA0,前三位是大写字母,后面一位是数字,可以hash转化成为一个对应的数字。然后可以用set存储每位学生的课程序列,自动升序排列。

具体代码:

#include<iostream>
#include<algorithm>
#include<map>
#include<set>
using namespace std;
#define MAXN 2505
set<int> slist[200000];
int getid(char *student){
	int n0=student[0]-'A';
	int n1=student[1]-'A';
	int n2=student[2]-'A';
	int n3=student[3]-'0';
	return (((n0*26)+n1)*26+n2)*10+n3;
}
int main()
{
    int n,k;
    scanf("%d%d",&n,&k);
    for(int i=0;i<k;i++){
    	int course,num;
    	scanf("%d%d",&course,&num);
    	for(int j=0;j<num;j++){
    		char* student=new char[5];
	    	scanf("%s",student);
	    	int id=getid(student);
	    	slist[id].insert(course);
		}
	}
	for(int i=0;i<n;i++){
		char* student=new char[5];
    	scanf("%s",student);
    	int id=getid(student);
    	printf("%s %d",student,slist[id].size());
    	set<int>::iterator it=slist[id].begin();
    	while(it!=slist[id].end())
    		printf(" %d",*it++);
		printf("\n");
	}
    return 0;
}
全部评论

相关推荐

已老实求offer😫:有点像徐坤(没有冒犯的意思哈)
点赞 评论 收藏
分享
双非一本失业第二年:《机器视觉垃圾分类》
点赞 评论 收藏
分享
点赞 收藏 评论
分享
牛客网
牛客企业服务