PAT(stl)——1063. Set Similarity (25)

Given two sets of integers, the similarity of the sets is defined to be Nc/Nt*100%, where Nc is the number of distinct common numbers shared by the two sets, and Nt is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.

Input Specification:

Each input file contains one test case. Each case first gives a positive integer N (<=50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (<=104) and followed by M integers in the range [0, 109]. After the input of sets, a positive integer K (<=2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated by a space.

Output Specification:

For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.

Sample Input:
3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3
Sample Output:
50.0%
33.3%

题目大意:

求出指定两个集合nc(两集合间共同元素)/nt(两集合不同元素总和)的值。

题目解析:

set的使用。

具体代码:

#include<iostream>
#include<algorithm>
#include<set>
using namespace std;
set<int> s[55];
double common(set<int> a,set<int> b){
	set<int>::iterator ta=a.begin();
	set<int>::iterator tb=b.begin();
	int res=0;
	while(ta!=a.end()&&tb!=b.end()){
		if(*ta==*tb){
			res++;
			ta++;
			tb++;
		}else if(*ta<*tb)
			ta++;
		else
			tb++;
	}
	return (double)res;
}
int main()
{
    int n,m;
    scanf("%d",&n);
    for(int i=1;i<=n;i++){
    	int num;
    	scanf("%d",&num);
    	for(int j=0;j<num;j++){
    		int number;
    		scanf("%d",&number);
    		s[i].insert(number);
		}
	}
	scanf("%d",&m);
	for(int i=1;i<=m;i++){
		int a,b;
		scanf("%d%d",&a,&b);
		double nc=common(s[a],s[b]);
		double nt=s[a].size()+s[b].size()-nc;
		printf("%.1f%\n",nc/nt*100);
	}
    return 0;
}
全部评论

相关推荐

10-07 20:48
门头沟学院 Java
听说改名就会有offer:可能是实习上着班想到后面还要回学校给导师做牛马,看着身边都是21-25的年纪,突然emo了了
点赞 评论 收藏
分享
jack_miller:我给我们导员说我不在这里转正,可能没三方签了。导员说没事学校催的时候帮我想办法应付一下
点赞 评论 收藏
分享
点赞 收藏 评论
分享
牛客网
牛客企业服务