PAT(stl)——1071. Speech Patterns (25)

People often have a preference among synonyms of the same word. For example, some may prefer “the police”, while others may prefer “the cops”. Analyzing such patterns can help to narrow down a speaker’s identity, which is useful when validating, for example, whether it’s still the same person behind an online avatar.

Now given a paragraph of text sampled from someone’s speech, can you find the person’s most commonly used word?

Input Specification:

Each input file contains one test case. For each case, there is one line of text no more than 1048576 characters in length, terminated by a carriage return ‘\n’. The input contains at least one alphanumerical character, i.e., one character from the set [0-9 A-Z a-z].

Output Specification:

For each test case, print in one line the most commonly occurring word in the input text, followed by a space and the number of times it has occurred in the input. If there are more than one such words, print the lexicographically smallest one. The word should be printed in all lower case. Here a “word” is defined as a continuous sequence of alphanumerical characters separated by non-alphanumerical characters or the line beginning/end.

Note that words are case insensitive.

Sample Input:
Can1: “Can a can can a can? It can!”
Sample Output:
can 5

题目大意:

计数题。

题目解析:

可以用string作为map的键值,那就好做了。

具体代码:

#include<iostream>
#include<algorithm>
#include<string>
#include<map>
using namespace std;
map<string,int> m;
int main()
{
	string str,tmp;
	getline(cin,str);
	for(int i=0;i<str.size();i++){
		if(isalnum(str[i])){
			if(isupper(str[i]))
				str[i]=tolower(str[i]);
			tmp+=str[i];
		}
		if(!isalnum(str[i])||i==str.size()-1){
			if(!tmp.empty()){
				m[tmp]++;
				tmp.clear();
			}
		}
	}
	int max=0;
	string maxchar;
	for(auto it=m.begin();it!=m.end();it++){
		if(it->second>max){
			max=it->second;
			maxchar=it->first;
		}
	}
	cout<<maxchar<<" "<<max;
    return 0;
}
全部评论

相关推荐

点赞 评论 收藏
分享
03-05 12:52
吉林大学 Java
挣K存W养DOG:他的价值在于把他家里积攒的财富回馈给社会
点赞 评论 收藏
分享
佛系的本杰明反对画饼:个人看法,实习经历那段是败笔,可以删掉,它和你目标岗位没什么关系,没有用到什么专业技能,甚至会降低你项目经历内容的可信度。个人技能那里可以再多写一点,去boss直聘上看别人写的岗位要求,可以把你会的整合一下,比如熟悉常规的开关电源拓扑结构(BUCK、正激、反激、LLC等),熟悉常用的通信总线协议和通信接口,如UART,IIC,SPI等。简历首先是HR看的,HR大多不懂技术,会从简历里去找关键字,你没有那些关键字他可能就把你筛掉了,所以个人技能尽量针对着岗位描述写一下。还有电赛获佳绩,获奖了就写什么奖,没获奖就把获佳绩删了吧,要不会让人感觉夸大。
点赞 评论 收藏
分享
评论
点赞
收藏
分享

创作者周榜

更多
牛客网
牛客企业服务