PAT(链表)——1032. Sharing (25)-PAT甲级真题

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, “loading” and “being” are stored as showed in Figure 1.

Snip20160807_66
Figure 1
You are supposed to find the starting position of the common suffix (e.g. the position of “i” in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (<= 105), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is the letter contained by this node which is an English letter chosen from {a-z, A-Z}, and Next is the position of the next node.

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output “-1” instead.

Sample Input 1:
11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010
Sample Output 1:
67890
Sample Input 2:
00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1
Sample Output 2:
-1

题目大意:

如果两个单词后缀相同,输出共同后缀的起始位置。

题目解析:

用结构体保存下一个字母的位置和状态flag,从第一个单词的起始位置出发,一直遍历到结尾,沿途的字母的状态都设为true;再从第二个字母出发遍历,遇到状态为true的字母就是所求的。没有就输出-1。

具体代码:

#include<iostream>
#include<algorithm>
#include<vector>
using namespace std;
#define MAXN 100005
struct node{
	int nextid;
	bool flag;
}A[MAXN];
int main()
{
    int s1,s2,n;
    scanf("%d%d%d",&s1,&s2,&n);
	while(n--){
		int pre,post;
		char c;
		scanf("%d %c %d",&pre,&c,&post);
		A[pre].nextid=post;
	}
	while(s1!=-1){
		A[s1].flag=true;
		s1=A[s1].nextid;
	}
	while(s2!=-1&&A[s2].flag==false)
		s2=A[s2].nextid;
	if(s2==-1){
		printf("-1");
		return 0;
	}else{
		printf("%05d",s2);
	}
    return 0;
}
全部评论

相关推荐

Eeeeevans:都是校友,还是同届,我就说直白点,不委婉了,我相信你应该也不是个玻璃心,首先你觉得一个双非的绩点写简历上有用吗?班长职务有用吗?ccf有用吗?企业会关心你高数满分与否吗?第二,第一个项目实在太烂,一眼就能看出是外卖,还是毫无包装的外卖,使用JWT来鉴权,把热点数据放进Redis这两个点居然还能写进简历里,说难听点这两个东西都是学个几十分钟,调用个API就能完成的事情,在双非一本的条件下,这种项目你觉得能拿出手吗,第二个项目你写的东西和你的求职方向有任何的匹配吗?第三,计设那一块毫无价值,如果想突出自己会前端,直接写入专业技能不行吗,最后,专业技能里像深入理解JVM底层原理这种你觉得这句话你自己真的能匹配吗?都是校友加上同届,我措辞直接,但希望能点出你的问题,想进大厂还得继续沉淀项目和学习
点赞 评论 收藏
分享
评论
点赞
收藏
分享

创作者周榜

更多
牛客网
牛客企业服务