PAT(链表)——1052. Linked List Sorting (25)-PAT甲级真题

A linked list consists of a series of structures, which are not necessarily adjacent in memory. We assume that each structure contains an integer key and a Next pointer to the next structure. Now given a linked list, you are supposed to sort the structures according to their key values in increasing order.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive N (< 105) and an address of the head node, where N is the total number of nodes in memory and the address of a node is a 5-digit positive integer. NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Key Next

where Address is the address of the node in memory, Key is an integer in [-105, 105], and Next is the address of the next node. It is guaranteed that all the keys are distinct and there is no cycle in the linked list starting from the head node.

Output Specification:

For each test case, the output format is the same as that of the input, where N is the total number of nodes in the list and all the nodes must be sorted order.

Sample Input:
5 00001
11111 100 -1
00001 0 22222
33333 100000 11111
12345 -1 33333
22222 1000 12345
Sample Output:
5 12345
12345 -1 00001
00001 0 11111
11111 100 22222
22222 1000 33333
33333 100000 -1

题目大意:

链表中的节点按照value排序。

题目解析:

排除掉不在链表的节点,排序就行了。

具体代码:

#include<iostream>
#include<algorithm>
#include<vector>
using namespace std;
#define MAXN 100005
struct node{
	int address;
	int value;
	int nextaddress;
	int flag;
}A[MAXN];
bool cmp(node a,node b){
	if(a.flag!=b.flag)
		return a.flag>b.flag;
	else 
		return a.value<b.value;
}
int main()
{
    int n,start;
    scanf("%d%d",&n,&start);
	for(int i=0;i<n;i++){
		int pre,data,post;
		scanf("%d%d%d",&pre,&data,&post);
		A[pre]={pre,data,post,0};
	}
	int k=0;
	while(start!=-1){
		k++;
		A[start].flag=1;
		start=A[start].nextaddress;
	}
	sort(A,A+100005,cmp);
	if(k==0){
		printf("0 -1");
		return 0;
	}
	printf("%d %05d\n",k,A[0].address);
	for(int i=0;i<k;i++){
		if(i!=k-1){
			printf("%05d %d %05d\n",A[i].address,A[i].value,A[i+1].address);
		}else{
			printf("%05d %d -1\n",A[i].address,A[i].value);
		}
	}
    return 0;
}
全部评论

相关推荐

11-09 14:54
已编辑
华南农业大学 产品经理
大拿老师:这个简历,连手机号码和照片都没打码,那为什么关键要素求职职位就不写呢? 从上往下看,都没看出自己到底是产品经理的简历,还是电子硬件的简历? 这是一个大问题,当然,更大的问题是实习经历的描述是不对的 不要只是去写实习流程,陈平,怎么去开会?怎么去讨论? 面试问的是你的产品功能点,是怎么设计的?也就是要写项目的亮点,有什么功能?这个功能有什么难处?怎么去解决的? 实习流程大家都一样,没什么优势,也没有提问点,没有提问,你就不得分 另外,你要明确你投的是什么职位,如果投的是产品职位,你的项目经历写的全都是跟产品无关的,那你的简历就没用 你的面试官必然是一个资深的产品经理,他不会去问那些计算机类的编程项目 所以这种四不像的简历,在校招是大忌
点赞 评论 收藏
分享
拉丁是我干掉的:把上海理工大学改成北京理工大学。成功率增加200%
点赞 评论 收藏
分享
点赞 收藏 评论
分享
牛客网
牛客企业服务