PAT(链表)——1074. Reversing Linked List (25)
Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K = 3, then you must output 3→2→1→6→5→4; if K = 4, you must output 4→3→2→1→5→6.
Input Specification:
Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (<= 105) which is the total number of nodes, and a positive K (<=N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.
Then N lines follow, each describes a node in the format:
Address Data Next
where Address is the position of the node, Data is an integer, and Next is the position of the next node.
Output Specification:
For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.
Sample Input:
00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218
Sample Output:
00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1
题目大意:
反转字符串,每k个元素反转一次。
题目解析:
简单模拟。
具体代码:
#include<iostream>
#include<algorithm>
#include<vector>
#include<map>
using namespace std;
#define MAXN 100005
struct node{
int address;
int data;
int count;
}v[MAXN];
map<int,node> m;
bool cmp(node a,node b){
return a.count>b.count;
}
int main()
{
int start,n,k;
scanf("%d%d%d",&start,&n,&k);
for(int i=0;i<n;i++){
int pre,data,post;
scanf("%d%d%d",&pre,&data,&post);
m[pre]={post,data,0};
}
int tmp=start,count=0;
while(tmp!=-1){
v[count]={tmp,m[tmp].data,count};
tmp=m[tmp].address;
count++;
}
for(int i=0;i+k<=count;i+=k){
sort(v+i,v+i+k,cmp);
}
for(int i=0;i<count-1;i++)
printf("%05d %d %05d\n",v[i].address,v[i].data,v[i+1].address);
printf("%05d %d -1\n",v[count-1].address,v[count-1].data);
return 0;
}