PAT(大数)——1024. Palindromic Number (25)

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and K, where N (<= 10^10) is the initial numer and K (<= 100) is the maximum number of steps. The numbers are separated by a space.

Output Specification:

For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.

Sample Input 1:
67 3
Sample Output 1:
484
2
Sample Input 2:
69 3
Sample Output 2:
1353
3

题目大意:

大整数相加+模拟。

题目解析:

这里用vector保存数据,模拟大数相加。

具体代码:

#include<iostream>
#include<algorithm>
#include<vector>
using namespace std;
vector<int> add(vector<int> &a,vector<int> &b){
	vector<int> res;
	int flag=0;
	for(int i=0;i<a.size();i++){
		int tmp=a[i]+b[i]+flag;
		if(tmp>=10)
			flag=1;
		else
			flag=0;
		res.push_back(tmp%10);
	}
	if(flag==1)
		res.push_back(1);
	return res;
}
bool judge(vector<int> &a){
	for(int i=0;i<a.size()/2;i++)
		if(a[i]!=a[a.size()-1-i])
			return false;
	return true;
}
void print(vector<int> &a){
	for(int i=a.size()-1;i>=0;i--)
		cout<<a[i];
}
int main()
{
    string s;
    int k;
    vector<int> pre,post;
    cin>>s>>k;
    for(int i=s.size()-1;i>=0;i--)
    	pre.push_back(s[i]-'0');
	for(int i=0;i<=k;i++){
		if(judge(pre)==true||i==k){
			print(pre);
			cout<<endl<<i;
			return 0;
		}
		post=pre;
		reverse(post.begin(),post.end());
		pre=add(pre,post);
	}
    return 0;
}
全部评论

相关推荐

预计下个星期就能开奖吧,哪位老哥来给个准信
华孝子爱信等:对接人上周说的是这周
点赞 评论 收藏
分享
11-15 19:28
已编辑
蚌埠坦克学院 硬件开发
点赞 评论 收藏
分享
dongsheng66:如果想进大厂的话,在校经历没必要占这么大篇幅,可以把专业技能单独放一个专栏写,可以加个项目经历
点赞 评论 收藏
分享
点赞 收藏 评论
分享
牛客网
牛客企业服务