PAT(贪心)——1037. Magic Coupon (25)
The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product… but hey, magically, they have some coupons with negative N’s!
For example, given a set of coupons {1 2 4 -1}, and a set of product values {7 6 -2 -3} (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.
Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.
Input Specification:
Each input file contains one test case. For each case, the first line contains the number of coupons NC, followed by a line with NC coupon integers. Then the next line contains the number of products NP, followed by a line with NP product values. Here 1<= NC, NP <= 105, and it is guaranteed that all the numbers will not exceed 230.
Output Specification:
For each test case, simply print in a line the maximum amount of money you can get back.
Sample Input:
4
1 2 4 -1
4
7 6 -2 -3
Sample Output:
43
题目大意:
一组优惠券和一组产品价格,优惠券和产品同时使用会得到两者乘积的奖金,最多能得到多少奖金。
题目解析:
最优方案为正值优惠券和正值产品从大到小选择,负值优惠券和正值产品从小到大选择。
具体代码:
#include<iostream>
#include<algorithm>
#include<vector>
using namespace std;
vector<int> c1,c2,p1,p2;
bool cmp(int a,int b){
return a>b;
}
int main()
{
int n,m,tmp;
cin>>n;
for(int i=0;i<n;i++){
cin>>tmp;
if(tmp>0)
c1.push_back(tmp);
else
c2.push_back(tmp);
}
cin>>m;
for(int i=0;i<m;i++){
cin>>tmp;
if(tmp>0)
p1.push_back(tmp);
else
p2.push_back(tmp);
}
sort(c1.begin(),c1.end(),cmp);
sort(c2.begin(),c2.end());
sort(p1.begin(),p1.end(),cmp);
sort(p2.begin(),p2.end());
int sum=0;
for(int i=0;i<c1.size()&&i<p1.size();i++)
sum+=c1[i]*p1[i];
for(int i=0;i<c2.size()&&i<p2.size();i++)
sum+=c2[i]*p2[i];
cout<<sum;
return 0;
}