PAT(贪心)——1070. Mooncake (25)

Mooncake is a Chinese bakery product traditionally eaten during the Mid-Autumn Festival. Many types of fillings and crusts can be found in traditional mooncakes according to the regions culture. Now given the inventory amounts and the prices of all kinds of the mooncakes, together with the maximum total demand of the market, you are supposed to tell the maximum profit that can be made.
Note: partial inventory storage can be taken. The sample shows the following situation: given three kinds of mooncakes with inventory amounts being 180, 150, and 100 thousand tons, and the prices being 7.5, 7.2, and 4.5 billion yuans. If the market demand can be at most 200 thousand tons, the best we can do is to sell 150 thousand tons of the second kind of mooncake, and 50 thousand tons of the third kind. Hence the total profit is 7.2 + 4.5/2 = 9.45 (billion yuans).

Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive integers N (<=1000), the number of different kinds of mooncakes, and D (<=500 thousand tons), the maximum total demand of the market. Then the second line gives the positive inventory amounts (in thousand tons), and the third line gives the positive prices (in billion yuans) of N kinds of mooncakes. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print the maximum profit (in billion yuans) in one line, accurate up to 2 decimal places.

Sample Input:
3 200
180 150 100
7.5 7.2 4.5
Sample Output:
9.45

题目大意:

给出不同的月饼数量和总价格,给出供应量,求出盈利最大的方案。

题目解析:

把月饼按照盈利从大到小排序,优先销售盈利大的。

具体代码:

#include<iostream>
#include<algorithm>
using namespace std;
#define MAXN 1005 
struct node{
	double num;
	double price;
	double average;
}A[MAXN];
bool cmp(node a,node b){
	return a.average>b.average;
}
int main()
{
	int n,sum;
	cin>>n>>sum;
	for(int i=0;i<n;i++)
		cin>>A[i].num;
	for(int i=0;i<n;i++){
		cin>>A[i].price;
		A[i].average=A[i].price/A[i].num;
	}
	sort(A,A+n,cmp);
	double price=0;
	for(int i=0;i<n;i++){
		if(A[i].num>sum){
			price+=A[i].price*sum/A[i].num;
			break;
		}else{
			price+=A[i].price;
			sum-=A[i].num;
		}
	}
	printf("%.2f",price);
    return 0;
}
全部评论

相关推荐

one_t:硕还是本?什么岗
点赞 评论 收藏
分享
点赞 收藏 评论
分享
牛客网
牛客企业服务