PAT(并查集)——1118. Birds in Forest (25)

Some scientists took pictures of thousands of birds in a forest. Assume that all the birds appear in the same picture belong to the same tree. You are supposed to help the scientists to count the maximum number of trees in the forest, and for any pair of birds, tell if they are on the same tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (<= 104) which is the number of pictures. Then N lines follow, each describes a picture in the format:
K B1 B2 … BK
where K is the number of birds in this picture, and Bi’s are the indices of birds. It is guaranteed that the birds in all the pictures are numbered continuously from 1 to some number that is no more than 104.

After the pictures there is a positive number Q (<= 104) which is the number of queries. Then Q lines follow, each contains the indices of two birds.

Output Specification:

For each test case, first output in a line the maximum possible number of trees and the number of birds. Then for each query, print in a line “Yes” if the two birds belong to the same tree, or “No” if not.

Sample Input:
4
3 10 1 2
2 3 4
4 1 5 7 8
3 9 6 4
2
10 5
3 7
Sample Output:
2 10
Yes
No

题目大意:

有几组照片,同一张照片上出现的鸟在同一棵树上,求最多几棵树,一共几只鸟,以及任意给两只鸟,求是否在同一棵树上。

题目解析:

并查集的题目,为了记录鸟儿的编号,可以使用set来存储鸟儿编号,因为多次出现的鸟儿只记录一个。

具体代码:

#include<iostream>
#include<algorithm>
#include<set>
using namespace std;
#define MAXN 10005
int parent[MAXN];
set<int> birds;
int num[MAXN];
int find_parent(int x){
	int a=x;
	while(x!=parent[x])
		x=parent[x];
	while(a!=parent[a]){//路径压缩 
		int b=a;
		parent[b]=x;
		a=parent[a];
	}
	return x;
}
void Union(int a,int b){
	int fa=find_parent(a);
	int fb=find_parent(b);
	if(fa!=fb){
		parent[fa]=fb;
	}
}
int main()
{
    int n;
    cin>>n;
    for(int i=0;i<MAXN;i++)
    	parent[i]=i;
    for(int i=0;i<n;i++){
    	int k,first;
    	cin>>k>>first;
    	birds.insert(first);
    	for(int j=0;j<k-1;j++){
    		int tmp;
    		cin>>tmp;
    		birds.insert(tmp);
    		Union(first,tmp);
		}
	}
	for(auto it=birds.begin();it!=birds.end();it++){
		int root=find_parent(*it);
		num[root]++;
	}
	int tree_num=0,bird_num=0;
	for(auto it=birds.begin();it!=birds.end();it++){
		if(num[*it]!=0){
			tree_num++;
			bird_num+=num[*it];
		}
	}
	cout<<tree_num<<" "<<bird_num<<endl;
	cin>>n;
	for(int i=0;i<n;i++){
		int a,b;
		cin>>a>>b;
		if(find_parent(a)==find_parent(b))
			cout<<"Yes"<<endl;
		else
			cout<<"No"<<endl;
	}
    return 0;
}
全部评论

相关推荐

最近和朋友聊天,她说了句让我震惊的话:"我发现我连周末点外卖都开始'最优解'了,一定要赶在高峰期前下单,不然就觉得自己亏了。"这不就是典型的"班味入侵"吗?工作思维已经渗透到生活的方方面面。
小型域名服务器:啊?我一直都这样啊?我还以为是我爱贪小便宜呢?每次去实验室都得接一杯免费的开水回去,出门都得规划一下最短路径,在宿舍就吃南边的食堂,在实验室就吃北边的食堂,快递只有顺路的时候才取。
点赞 评论 收藏
分享
一颗宏心:华为HR晚上过了十二点后还给我法消息。
点赞 评论 收藏
分享
不愿透露姓名的神秘牛友
09-30 19:49
起名星人:蛮离谱的,直接要求转投销售
投递汇川技术等公司10个岗位
点赞 评论 收藏
分享
不愿透露姓名的神秘牛友
11-21 19:05
点赞 评论 收藏
分享
点赞 收藏 评论
分享
牛客网
牛客企业服务