PAT(并查集)——1107. Social Clusters (30)
When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A “social cluster” is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.
Input Specification:
Each input file contains one test case. For each test case, the first line contains a positive integer N (<=1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:
Ki: hi[1] hi[2] … hi[Ki]
where Ki (>0) is the number of hobbies, and hi[j] is the index of the j-th hobby, which is an integer in [1, 1000].
Output Specification:
For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.
Sample Input:
8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4
Sample Output:
3
4 3 1
题目大意:
两个人有一样的爱好就称为处于同一个社交网络,求一共有多少个社交网络,人数从大到小输出。
题目解析:
以人作为节点,对爱好做一个到人的映射,其他的就跟正常的并查集题目一样了。
具体代码:
#include<iostream>
#include<algorithm>
#include<vector>
using namespace std;
#define MAXN 1005
int parent[MAXN];
int num[MAXN];
int course[MAXN];
void init(){
for(int i=0;i<MAXN;i++){
parent[i]=i;
course[i]=0;
num[i]=0;
}
}
int find_parent(int x){
int a=x;
while(x!=parent[x])
x=parent[x];
while(a!=parent[a]){//路径压缩
int b=a;
parent[b]=x;
a=parent[a];
}
return x;
}
void Union(int a,int b){
int fa=find_parent(a);
int fb=find_parent(b);
if(fa!=fb){
parent[fa]=fb;
}
}
bool cmp(int a,int b){
return a>b;
}
int main()
{
int n;
cin>>n;
init();
for(int i=1;i<=n;i++){
int k;
scanf("%d:",&k);
while(k--){
int tmp;
cin>>tmp;
if(course[tmp]==0)
course[tmp]=i;
Union(i,find_parent(course[tmp]));
}
}
for(int i=1;i<=n;i++){
num[find_parent(i)]++;
}
sort(num,num+MAXN,cmp);
vector<int> v;
for(int i=0;i<MAXN;i++){
if(num[i]==0)
break;
v.push_back(num[i]);
}
cout<<v.size()<<endl;
for(int i=0;i<v.size();i++){
if(i==v.size()-1)
cout<<v[i];
else
cout<<v[i]<<" ";
}
return 0;
}