NBUT- 1228 J - Bored Three - God

题目链接:https://cn.vjudge.net/problem/NBUT-1228

题目

The bored Three-God get another boring question.
This problem is ask you plus two big nubmer, please help him, when you solve this problem you can
speak to Three-God,“Oh, Please give me a diffculte one, this one is too easy”.

input

There are muti-case
For each case, there are two integers, n, m (0 < n, m < 10^10000).

output

Calculate two integers’ sum

Sample Input

1 1
2 3
10000 100000

Sample Output

2
5
110000

Hint

就是一个大数加法;
坑点就是要输出前导0;
比如005, 006要输出011。

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<algorithm>
using namespace std;
int a[100003],b[100003],c[100004];
char x[100005],y[100005];
int main()
{
    while(~scanf("%s%s",x,y))
    {
       memset(a,0,sizeof(a));
       memset(b,0,sizeof(b));
       memset(c,0,sizeof(c));
        int la=0;
        int lb=0;
        int lc=0;
        int lx=strlen(x);
        int ly=strlen(y); int w=0;int k=0;
        for(int i=lx-1;i>=0;i--)
        {

            a[w++]=x[i]-'0';
        }
        for(int i=ly-1;i>=0;i--)
        {

            b[k++]=y[i]-'0';
        }
        int mm=max(w,k);

        for(int i=0;i<mm;i++)
        {
            int s=a[i]+b[i];

            c[i]+=s;

            c[i+1]=c[i]/10;
             c[i]%=10;
        }
        int flog=0;
        if(c[mm])
        {
            printf("%d",c[mm]);
        }
        for(int j=mm-1;j>=0;j--)
        {
                printf("%d",c[j]);

        }
        printf("\n");
    }
    return 0;
}
全部评论

相关推荐

ProMonkey2024:5个oc?厉害! 但是有一个小问题:谁问你了?😡我的意思是,谁在意?我告诉你,根本没人问你,在我们之中0人问了你,我把所有问你的人都请来 party 了,到场人数是0个人,誰问你了?WHO ASKED?谁问汝矣?誰があなたに聞きましたか?누가 물어봤어?我爬上了珠穆朗玛峰也没找到谁问你了,我刚刚潜入了世界上最大的射电望远镜也没开到那个问你的人的盒,在找到谁问你之前我连癌症的解药都发明了出来,我开了最大距离渲染也没找到谁问你了我活在这个被辐射蹂躏了多年的破碎世界的坟墓里目睹全球核战争把人类文明毁灭也没见到谁问你了(别的帖子偷来的,现学现卖😋)
点赞 评论 收藏
分享
不愿透露姓名的神秘牛友
10-05 10:13
已编辑
HHHHaos:让这些老登来现在秋招一下,简历都过不去
点赞 评论 收藏
分享
评论
点赞
收藏
分享
牛客网
牛客企业服务