Factors of Factorial(思维公式)

Problem Statement

You are given an integer N. Find the number of the positive divisors of N!, modulo 109+7.

Constraints
  • 1≤N≤103
Input
  • The input is given from Standard Input in the following format:
  • N
Output
  • Print the number of the positive divisors of N!, modulo 109+7.
Sample Input 1

3

Sample Output 1

4
There are four divisors of 3! =6: 1, 2, 3 and 6. Thus, the output should be 4.

Sample Input 2

6

Sample Output 2

30

Sample Input 3

1000

Sample Output 3

972926972

解析:分解定理可知,把2~N每个数分解质因数并统计每个质因数出现的个数,然后由公式得出因子个数(a[2]+1)(a[3]+1)(a[4]+1)*……(a[n]+1),前提是a[i]不为0,为0是没有质因数

#include <cstdio>
#include <cstring>
#include <cmath>

using namespace std;

const int maxn=1e9+7;
int a[1005];

int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        memset(a,0,sizeof(a));   //a数组赋初值为0
        int c=0;
        for(int i=2; i<=n; i++)
        {
            int l=i;
            for(int j=2; j<=l; j++)
            {
                while(l%j==0)
                {
                    a[j]++;//把每个数de每个素因子的个数存起来
                    l/=j;
                }
            }

        }
        long long sum=1;
        for(int i=2; i<=n; i++)
        {
            if(a[i])
            {
                sum*=(1+a[i]);
                sum=sum%maxn;
            }
        }
        printf("%lld\n",sum%maxn);
    }
    return 0;

}

Thank for you like!

全部评论

相关推荐

01-23 14:54
同济大学 Java
热爱敲代码的程序媛:给你提几点【专业技能】这个模块里面可优化的地方:1.【具备JVM调优经验】可以去b站上搜一下JVM调优的视频,估计一两个小时凭你的学习能力就能掌握JVM调优的实践方面的技能。2.【MySql优化】MySql这一栏,你去b站或者找个博客看看MySql优化,学一下,如果你本身比较熟悉MySql语句的话,那基本半天时间凭你的学习能力MySql语句优化方面的技能你也能掌握个差不多。以上1,2两点主要是因为我看你专业技能大部分都说的是偏理论,没有写应用。再就是最后,你结合你的项目,想一想你的项目中哪些sql语句是可以用MySql优化的,到时候你面试的时候也好结合着说一下。
点赞 评论 收藏
分享
菜鸡29号:根据已有信息能初步得出以下几点: 1、硕士排了大本和大专 2、要求会多语言要么是招人很挑剔要么就是干的活杂 3、给出校招薪资范围过于巨大,说明里面的薪资制度(包括涨薪)可能有大坑
点赞 评论 收藏
分享
评论
点赞
收藏
分享

创作者周榜

更多
牛客网
牛客企业服务