天梯赛 L2-004 这是二叉搜索树吗? (25 分) (树)
一棵二叉搜索树可被递归地定义为具有下列性质的二叉树:对于任一结点,
其左子树中所有结点的键值小于该结点的键值;
其右子树中所有结点的键值大于等于该结点的键值;
其左右子树都是二叉搜索树。
所谓二叉搜索树的“镜像”,即将所有结点的左右子树对换位置后所得到的树。
给定一个整数键值序列,现请你编写程序,判断这是否是对一棵二叉搜索树或其镜像进行前序遍历的结果。
输入格式:
输入的第一行给出正整数 N(≤1000)。随后一行给出 N 个整数键值,其间以空格分隔。
输出格式:
如果输入序列是对一棵二叉搜索树或其镜像进行前序遍历的结果,则首先在一行中输出 YES ,然后在下一行输出该树后序遍历的结果。数字间有 1 个空格,一行的首尾不得有多余空格。若答案是否,则输出 NO。
输入样例 1:
7
8 6 5 7 10 8 11
输出样例 1:
YES
5 7 6 8 11 10 8
输入样例 2:
7
8 10 11 8 6 7 5
输出样例 2:
YES
11 8 10 7 5 6 8
输入样例 3:
7
8 6 8 5 10 9 11
输出样例 3:
NO
solution:经典的二叉树,就当复习了一遍吧
#include<iostream>
#include<vector>
using namespace std;
struct node {
int data;
node* lchild;
node* rchild;
};
int num[1000], n;
node* newnode(int x)
{
node* newnode = new node;
newnode->data = x;
newnode->lchild = newnode->rchild = NULL;
return newnode;
}
void insert(node* &root, int x)
{
if (root == NULL)
{
root = newnode(x);
return;
}
if (x >= root->data)insert(root->rchild, x);
else insert(root->lchild, x);
}
node* create(int num[], int n)
{
node* root = NULL;
for (int i = 0; i < n; i++)insert(root, num[i]);
return root;
}
vector<int>pre, mirror_pre, post;
void preorder(node* root)
{
if (root == NULL)return;
pre.push_back(root->data);
preorder(root->lchild);
preorder(root->rchild);
}
void mirrororder(node* root)
{
if (root == NULL)return;
mirror_pre.push_back(root->data);
mirrororder(root->rchild);
mirrororder(root->lchild);
}
bool issame(vector<int>pre)
{
for (int i = 0; i < n; i++)
{
if (pre[i] != num[i])return false;
}
return true;
}
void postorder(node* root)
{
if (root == NULL)return;
postorder(root->lchild);
postorder(root->rchild);
post.push_back(root->data);
}
void postorder_mirror(node* root)
{
if (root == NULL)return;
postorder_mirror(root->rchild);
postorder_mirror(root->lchild);
post.push_back(root->data);
}
int main()
{
scanf("%d", &n);
for (int i = 0; i < n; i++)scanf("%d", &num[i]);
node* root = create(num, n);
preorder(root);
mirrororder(root);
if(issame(pre)||issame(mirror_pre))
{
printf("YES\n");
if (issame(pre))
postorder(root);
else if (issame(mirror_pre))
postorder_mirror(root);
for (int i = 0; i < post.size(); i++)
{
printf("%d", post[i]);
if (i != post.size() - 1)printf(" ");
}
}
else printf("NO");
return 0;
}