简单计算器

读入一个只包含 +, -, *, / 的非负整数计算表达式,计算该表达式的值。

Input

测试输入包含若干测试用例,每个测试用例占一行,每行不超过200个字符,整数和运算符之间用一个空格分隔。没有非法表达式。当一行中只有0时输入结束,相应的结果不要输出。

Output

对每个测试用例输出1行,即该表达式的值,精确到小数点后2位。

Sample Input

1 + 2
4 + 2 * 5 - 7 / 11
0

Sample Output

3.00
13.36

思路:简单的表达式求值,用栈模拟即可。注意结束条件,即当输入只有0时才结束,输入0 * 9 等类似的表达式,不结束。

 

#include<stdio.h>
#include<algorithm>
#include<stack>
using namespace std;
stack<double> s;
double a;
char ch,f;
double a0,a1,ans;
int main()
{
    while(scanf("%lf",&a))
    {
        ans=0;
        s.push(a);//入栈
        f=getchar();
        if(f!='\n')
        {
            do
            {
                scanf("%c%lf",&ch,&a0);
                if(ch=='-')
                    a0=0-a0;
                if(ch=='*')
                {
                    a1=s.top();
                    s.pop();
                    a0=a0*a1;
                }
                if(ch=='/')
                {
                    a1=s.top();
                    s.pop();
                    a0=a1/a0;
                }
                s.push(a0);
            }
            while(scanf("%c",&ch),ch!='\n');
        }

        else if(s.size()==1&&s.top()==0)

            return 0;

        while(!s.empty())
        {
            ans+=s.top();
            s.pop();
        }
        printf("%.2lf\n",ans);
    }
    return 0;
}

 

全部评论

相关推荐

评论
点赞
收藏
分享

创作者周榜

更多
牛客网
牛客企业服务