problem D Space Golf(枚举)
题目链接:点击打开链接
文章转载自:xuanqis.com
Description
You surely have never heard of this new planet surface exploration scheme, as it is being carried out in a project with utmost secrecy. The scheme is expected to cut costs of conventional rover-type mobile explorers considerably, using projected-type equipment nicknamed “observation bullets”.
Bullets do not have any active mobile abilities of their own, which is the main reason of their cost-efficiency. Each of the bullets, after being shot out on a launcher given its initial velocity, makes a parabolic trajectory until it touches down. It bounces on the surface and makes another parabolic trajectory. This will be repeated virtually infinitely.
We want each of the bullets to bounce precisely at the respective spot of interest on the planet surface, adjusting its initial velocity. A variety of sensors in the bullet can gather valuable data at this instant of bounce, and send them to the observation base. Although this may sound like a conventional target shooting practice, there are several issues that make the problem more difficult.
There may be some obstacles between the launcher and the target spot. The obstacles stand upright and are very thin that we can ignore their widths. Once the bullet touches any of the obstacles, we cannot be sure of its trajectory thereafter. So we have to plan launches to avoid these obstacles.
Launching the bullet almost vertically in a speed high enough, we can easily make it hit the target without touching any of the obstacles, but giving a high initial speed is energy-consuming. Energy is extremely precious in space exploration, and the initial speed of the bullet should be minimized. Making the bullet bounce a number of times may make the bullet reach the target with lower initial speed.
The bullet should bounce, however, no more than a given number of times. Although the body of the bullet is made strong enough, some of the sensors inside may not stand repetitive shocks. The allowed numbers of bounces vary on the type of the observation bullets.
You are summoned engineering assistance to this project to author a smart program that tells the minimum required initial speed of the bullet to accomplish the mission.
Figure D.1 gives a sketch of a situation, roughly corresponding to the situation of the Sample Input 4 given below.
Figure D.1. A sample situation
Figure D.1. A sample situation
You can assume the following.
The atmosphere of the planet is so thin that atmospheric resistance can be ignored.
The planet is large enough so that its surface can be approximated to be a completely flat plane.
The gravity acceleration can be approximated to be constant up to the highest points a bullet can reach.
These mean that the bullets fly along a perfect parabolic trajectory.
You can also assume the following.
The surface of the planet and the bullets are made so hard that bounces can be approximated as elastic collisions. In other words, loss of kinetic energy on bounces can be ignored. As we can also ignore the atmospheric resistance, the velocity of a bullet immediately after a bounce is equal to the velocity immediately after its launch.
The bullets are made compact enough to ignore their sizes.
The launcher is also built compact enough to ignore its height.
You, a programming genius, may not be an expert in physics. Let us review basics of rigid-body dynamics.
We will describe here the velocity of the bullet v with its horizontal and vertical components vx and vy (positive meaning upward). The initial velocity has the components vix and viy, that is, immediately after the launch of the bullet, vx = vix and vy = viy hold. We denote the horizontal distance of the bullet from the launcher as x and its altitude as y at time t.
The horizontal velocity component of the bullet is kept constant during its flight when atmospheric resistance is ignored. Thus the horizontal distance from the launcher is proportional to the time elapsed.
x=vixt(1)
The vertical velocity component vy is gradually decelerated by the gravity. With the gravity acceleration of g, the following differential equation holds during the flight.
dvydt=−g(2)
Solving this with the initial conditions of vy = viy and y = 0 when t = 0, we obtain the following.
y==−12gt2+viyt−(12gt−viy)t(3)(4)
The equation (4) tells that the bullet reaches the ground again when t = 2viy/g. Thus, the distance of the point of the bounce from the launcher is 2vixviy/g. In other words, to make the bullet fly the distance of l, the two components of the initial velocity should satisfy 2vixviy = lg.
Eliminating the parameter t from the simultaneous equations above, we obtain the following equation that escribes the parabolic trajectory of the bullet.
y=−(g2v2ix)x2+(viyvix)x(5)
For ease of computation, a special unit system is used in this project, according to which the gravity acceleration g of the planet is exactly 1.0.
Input
The input consists of several tests case with the following format.
d n bp1 h1p2 h2⋮pn hn
For each test, the first line contains three integers, d, n, and b. Here, d is the distance from the launcher to the target spot (1 ≤ d ≤ 10000), n is the number of obstacles (1 ≤ n ≤ 10), and b is the maximum number of bounces allowed, not including the bounce at the target spot (0 ≤ b ≤ 15).
Each of the following n lines has two integers. In the k-th line, pk is the position of the k-th obstacle, its distance from the launcher, and hk is its height from the ground level. You can assume that 0 < p1, pk < pk + 1 for k = 1, …, n − 1, and pn < d. You can also assume that 1 ≤ hk ≤ 10000 for k = 1, …, n.
Output
Output the smallest possible initial speed vi that makes the bullet reach the target. The initial speed vi of the bullet is defined as follows.
vi=v2ix+v2iy−−−−−−−√
The output should not contain an error greater than 0.0001.
Sample Input
100 1 0
50 100
10 1 0
4 2
100 4 3
20 10
30 10
40 10
50 10
343 3 2
56 42
190 27
286 34
Sample Output
14.57738
3.16228
7.78175
11.08710
Hint
Source
Asia Regional Contest, Tokyo, 2014
题意
从起点弹一个小球,这个球具有x方向和y方向的初速度。起点和终点的距离是d,这个中间存在n个障碍物,小球最多只能在中间蹦b次。给出每个障碍物的位置和高度,要求求出小球所具有的最小初速度。
思路
首先枚举在中间蹦0次到b次,因为g=1,所以vy等于小球从起点到终点的时间t,由此得到d=vx * 2 * m * vy(m是蹦的次数加一)。然后由题目给出的y=-(g/(2 * vx * vx))x * x + (vy / vx) * x,能够得到vx = sqrt(abs(double(d * x – x * x * num) / double( 2 * y * num))),从而能够求出vx的临界值,求出vx的临界值,此时并不一定是最小的,vx * vx + vy * vy在 vx = vy的时候最小(高中的知识,忘记咋推啦),vx大,那么vy就小,如果vx大于vy,那么就还能更小,d = 2 * m * vx * vx -> vx = sqrt( 2 * d / 2 * num)。要注意上面的公式是在一个周期内成立的,在第二个周期内并不成立。所以将所有的障碍物移到第一个周期内考虑。
代码
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#define INF 0x3f3f3f3f
using namespace std;
int p[100],h[100];
double q[100];
int d, n, b;
double judge(int num){
double vx=0;
double ans =0;
for(int i=1;i<=n;i++){ //将障碍左移,存在q数组内
q[i]=p[i];
double length = double(d)/double(num);
while(q[i]>=length)
q[i]-=length;
q[i]+=0.00000001;
}
for(int i=1;i<=n;i++){
vx = sqrt(abs(double(d*q[i]-q[i]*q[i]*num)/double(2*h[i]*num)));
double vy = double(d)/double(2*vx*num);
if(vx>vy){ //还能更小
double numnum= sqrt(2 * double(d)/double(2*num));
numnum= min(numnum,sqrt(vx*vx+vy*vy));
ans=max(ans,numnum);
}
else
ans=max(ans, sqrt(vx*vx+vy*vy));
}
return ans;
}
int main(){
//freopen("2.txt", "r", stdin);
while(~scanf("%d%d%d", &d, &n, &b)){
memset(p,0,sizeof(p));
memset(h,0,sizeof(h));
for(int i=1;i<=n;i++){
scanf("%d%d", &p[i], &h[i]);
}
double ans=11111111;
for(int i=0;i<=b;i++){
ans=min(ans,judge(i+1)); //这里的参数是总的周期数
}
printf("%.5f\n", ans);
}
}