Price List

Price List

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/131072 K (Java/Others)
Total Submission(s): 296    Accepted Submission(s): 192


Problem Description
There are n shops numbered with successive integers from 1 to n in Byteland. Every shop sells only one kind of goods, and the price of the i -th shop's goods is vi .

Every day, Byteasar will purchase some goods. He will buy at most one piece of goods from each shop. Of course, he can also choose to buy nothing. Back home, Byteasar will calculate the total amount of money he has costed that day and write it down on his account book.

However, due to Byteasar's poor math, he may calculate a wrong number. Byteasar would not mind if he wrote down a smaller number, because it seems that he hadn't used too much money.

Please write a program to help Byteasar judge whether each number is sure to be strictly larger than the actual value.
 

 

Input
The first line of the input contains an integer T (1T10) , denoting the number of test cases.

In each test case, the first line of the input contains two integers n,m (1n,m100000) , denoting the number of shops and the number of records on Byteasar's account book.

The second line of the input contains n integers v1,v2,...,vn (1vi100000) , denoting the price of the i -th shop's goods.

Each of the next m lines contains an integer q (0q1018) , denoting each number on Byteasar's account book.
 

 

Output
For each test case, print a line with m characters. If the i -th number is sure to be strictly larger than the actual value, then the i -th character should be '1'. Otherwise, it should be '0'.
 

 

Sample Input
1 3 3 2 5 4 1 7 10000
 

 

Sample Output
001
 

 

Source
 

 

Recommend
wange2014   |   We have carefully selected several similar problems for you:   5808  5807  5806  5805  5804 
 
唉,昨晚只做出来一个题。
 
代码:
#include <iostream>
#include <cstdio>

using namespace std;

int main()
{
    int t;
    int n,m;
    int v=0;;
    int sum=0;
    int jilu[100005];
    int jieguo[100005];
    scanf("%d",&t);
    while(t--){
        sum=0;
        scanf("%d %d",&n,&m);
        for(int i=0;i<n;i++){
            scanf("%d",&v);
            sum+=v;
        }
        for(int j=0;j<m;j++){
            scanf("%d",&jilu[j]);
        }
        for(int j=0;j<m;j++){
            if(jilu[j]>sum){
                printf("1");
            }else{
                printf("0");
            }
        }
        printf("\n");


    }
    return 0;
}

 

全部评论

相关推荐

沉淀一会:1.同学你面试评价不错,概率很大,请耐心等待; 2.你的排名比较靠前,不要担心,耐心等待; 3.问题不大,正在审批,不要着急签其他公司,等等我们! 4.预计9月中下旬,安心过节; 5.下周会有结果,请耐心等待下; 6.可能国庆节前后,一有结果我马上通知你; 7.预计10月中旬,再坚持一下; 8.正在走流程,就这两天了; 9.同学,结果我也不知道,你如果查到了也告诉我一声; 10.同学你出线不明朗,建议签其他公司保底! 11.同学你找了哪些公司,我也在找工作。
点赞 评论 收藏
分享
死在JAVA的王小美:哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈,我也是,让我免了一轮,但是硬气拒绝了
点赞 评论 收藏
分享
评论
点赞
收藏
分享
牛客网
牛客企业服务