nyoj_148_fibonacci数列(二)_矩阵快速幂

fibonacci数列(二)

时间限制: 1000 ms  |  内存限制:65535 KB
难度: 3
 
<dl class="problem&#45;display"> <dt> 描述 </dt> <dd>

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

 

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

.

 

</dd> </dl>
 
<dl class="others"> <dt> 输入 </dt> <dd> The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1. </dd> <dt> 输出 </dt> <dd> For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000). </dd> <dt> 样例输入 </dt> <dd>
0
9
1000000000
-1
</dd> <dt> 样例输出 </dt> <dd>
0
34
6875
</dd> <dt> 来源 </dt> <dd> POJ </dd> <dt> 上传者 </dt> <dd> hzyqazasdf </dd> <dd> 解题思路: </dd> <dd> 一下午就学了这一个算法,有很多细节总是花很长时间才理解。感觉自己学习算法效率好低啊。 </dd> <dd> 之前刚接触斐波那契数列,想找一个更高效的方法来求,当时看到了,却根本不懂。原来这就是矩阵快速幂。。。从此有了求斐波那契数列更好的方法 </dd> <dd> 既然整数求幂可以用快速幂来求,那么矩阵的幂同样也可以啊。 </dd> </dl>
#include <iostream>
#include <cstdio>
#include <cstring>

#define mod 10000

using namespace std;

struct matrix{
    int m[2][2];
};

matrix base,ans;

void init(int n){//只初始化base和ans(单位矩阵)
    memset(base.m,0,sizeof(base.m));
    memset(ans.m,0,sizeof(ans.m));
    for(int i=0;i<2;i++){
        ans.m[i][i]=1;
    }

    base.m[0][0]=base.m[0][1]=base.m[1][0]=1;
}

matrix multi(matrix a,matrix b){
    matrix t;
    for(int i=0;i<2;i++){
        for(int j=0;j<2;j++){
            t.m[i][j]=0;
            for(int k=0;k<2;k++){
                t.m[i][j]=(t.m[i][j]+a.m[i][k]*b.m[k][j])%mod;
            }
        }
    }
    return t;
}

int fast_matrix(int n){
    while(n){
        if(n&1){
            ans=multi(ans,base);
        }
        base=multi(base,base);
        n>>=1;
    }
    return ans.m[1][0];
}

int main()
{
    int n;
    while(~scanf("%d",&n) && n!=-1){
        init(n);
        printf("%d\n",fast_matrix(n));
    }
    return 0;
}

 

全部评论

相关推荐

vegetable_more_exercise:1-1.5万,没错啊,最少是1人民币,在区间内
点赞 评论 收藏
分享
评论
点赞
收藏
分享
正在热议
# 25届秋招总结 #
442065次浏览 4508人参与
# 春招别灰心,我们一人来一句鼓励 #
41866次浏览 531人参与
# 阿里云管培生offer #
120195次浏览 2219人参与
# 地方国企笔面经互助 #
7957次浏览 18人参与
# 同bg的你秋招战况如何? #
76477次浏览 561人参与
# 虾皮求职进展汇总 #
115376次浏览 886人参与
# 北方华创开奖 #
107421次浏览 599人参与
# 实习,投递多份简历没人回复怎么办 #
2454553次浏览 34856人参与
# 实习必须要去大厂吗? #
55760次浏览 961人参与
# 提前批简历挂麻了怎么办 #
149886次浏览 1977人参与
# 投递实习岗位前的准备 #
1195903次浏览 18548人参与
# 你投递的公司有几家约面了? #
33203次浏览 188人参与
# 双非本科求职如何逆袭 #
662154次浏览 7394人参与
# 如果公司给你放一天假,你会怎么度过? #
4750次浏览 55人参与
# 机械人春招想让哪家公司来捞你? #
157622次浏览 2267人参与
# 如果你有一天可以担任公司的CEO,你会做哪三件事? #
11525次浏览 284人参与
# 发工资后,你做的第一件事是什么 #
12659次浏览 62人参与
# 工作中,努力重要还是选择重要? #
35779次浏览 384人参与
# 参加完秋招的机械人,还参加春招吗? #
20120次浏览 240人参与
# 我的上岸简历长这样 #
451995次浏览 8088人参与
# 实习想申请秋招offer,能不能argue薪资 #
39286次浏览 314人参与
# 非技术岗是怎么找实习的 #
155864次浏览 2120人参与
牛客网
牛客企业服务