hdu 1251 统计难题 字典树|map
Ignatius最近遇到一个难题,老师交给他很多单词(只有小写字母组成,不会有重复的单词出现),现在老师要他统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀).
Input
输入数据的第一部分是一张单词表,每行一个单词,单词的长度不超过10,它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问,每行一个提问,每个提问都是一个字符串.
注意:本题只有一组测试数据,处理到文件结束.
Output
对于每个提问,给出以该字符串为前缀的单词的数量.
Sample Input
banana
band
bee
absolute
acm
ba
b
band
abc
Sample Output
2
3
1
0
第一种 字典树
//140MS 43828K 1134 B G++
#include<stdio.h>
#include<string.h>
struct node{
int cnt;
node *next[27];
node(){
cnt=0;
memset(next,0,sizeof(next));
}
};
void insert(node *root,char s[])
{
int i=0;
node *p=root;
while(s[i]){
int j=s[i++]-'a';
if(p->next[j]==NULL) p->next[j]=new node();
p=p->next[j];
p->cnt+=1;
//printf("**%d\n",p->cnt);
}
}
int judge(node *root,char s[])
{
int i=0;
node *p=root;
int flag=0;
while(s[i]){
int j=s[i++]-'a';
if(p->next[j]==NULL){
flag=0;break;
}
p=p->next[j];
flag=p->cnt;
}
return flag;
}
int main(void)
{
node *root=new node();
char word[10];
char cur[10];
//freopen("C:\\Users\\Administrator\\Desktop\\in.txt","r",stdin);
//freopen("C:\\Users\\Administrator\\Desktop\\out.txt","w",stdout);
while(gets(word)){
if(strcmp(word,"")==0) break;
insert(root,word);
}
while(gets(cur)){
printf("%d\n",judge(root,cur));
}
return 0;
}
第二种 map
#include<bits/stdc++.h>
using namespace std;
int main()
{
map<string,int>mp;
string str;
while(getline(cin, str)&&str.length()!=0)
{
for(int i=1;i<=str.length();i++)
mp[str.substr(0,i)]++;
}
while(cin>>str)
{
printf("%d\n",mp[str]);
}
return 0;
}