POJ 1088 记忆化搜索
题面
滑雪
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 110107 | Accepted: 41935 |
Description
Michael喜欢滑雪百这并不奇怪, 因为滑雪的确很刺激。可是为了获得速度,滑的区域必须向下倾斜,而且当你滑到坡底,你不得不再次走上坡或者等待升降机来载你。Michael想知道载一个区域中最长底滑坡。区域由一个二维数组给出。数组的每个数字代表点的高度。下面是一个例子
1 2 3 4 5 16 17 18 19 6 15 24 25 20 7 14 23 22 21 8 13 12 11 10 9
一个人可以从某个点滑向上下左右相邻四个点之一,当且仅当高度减小。在上面的例子中,一条可滑行的滑坡为24-17-16-1。当然25-24-23-...-3-2-1更长。事实上,这是最长的一条。
Input
输入的第一行表示区域的行数R和列数C(1 <= R,C <= 100)。下面是R行,每行有C个整数,代表高度h,0<=h<=10000。
Output
输出最长区域的长度。
Sample Input
5 5 1 2 3 4 5 16 17 18 19 6 15 24 25 20 7 14 23 22 21 8 13 12 11 10 9
Sample Output
25
Source
算法
记忆化搜索
分别从每个点出发,搜索一次。利用数组记录求过的点的最长长度,避免每次都递归搜索。
AC代码
#include <iostream>
#include <string>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
using namespace std;
const int kMaxRow = 100;
const int kMaxCol = 100;
int row, col;
int height[kMaxRow][kMaxCol];
int longestFrom[kMaxRow][kMaxCol];
const int kGoCnt = 4;
int go[kGoCnt][2] = {{-1,0},{0,-1},{0,1},{1,0}};
int getLongestFrom(int i,int j) {
if (longestFrom[i][j])
return longestFrom[i][j];
int r,c;
longestFrom[i][j] = 1;
for (int d = 0;d < kGoCnt; ++d) {
r = i + go[d][0];
c = j + go[d][1];
//out of range
if (r < 0 || r >= row || c < 0 || c >= col)
continue;
if (height[i][j] <= height[r][c])
continue;
longestFrom[i][j] = max(longestFrom[i][j],1+getLongestFrom(r,c));
}
return longestFrom[i][j];
}
int main()
{
ios::sync_with_stdio(false);
cin.tie(0);
cin>>row>>col;
for (int i = 0;i < row; ++i)
for (int j = 0;j < col; ++j) {
cin>>height[i][j];
longestFrom[i][j] = 0;
}
int ans = 0;
for (int i = 0;i < row; ++i)
for (int j = 0;j < col; ++j) {
ans = max(ans,getLongestFrom(i,j));
}
cout<<ans<<'\n';
return 0;
}