PAT-A 1058. A+B in Hogwarts

If you are a fan of Harry Potter, you would know the world of magic has its own currency system – as Hagrid explained it to Harry, “Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it’s easy enough.” Your job is to write a program to compute A+B where A and B are given in the standard form of “Galleon.Sickle.Knut” (Galleon is an integer in [0, 107], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:

3.2.1 10.16.27

Sample Output:

14.1.28

程序代码:

#include<stdio.h>
int  a[3],b[3],c[3];
int main()
{
    scanf("%d.%d.%d",&a[2],&a[1],&a[0]);
    scanf("%d.%d.%d",&b[2],&b[1],&b[0]);
    int tmp;
    c[0]=(a[0]+b[0])%29;
    tmp = (a[0]+b[0])/29;
    c[1] = (tmp+a[1]+b[1])%17;
    tmp = (tmp+a[1]+b[1])/17;
    c[2]=(a[2]+b[2]+tmp);
    printf("%d.%d.%d",c[2],c[1],c[0]);
    return 0;
}
全部评论

相关推荐

北斗导航Compass低仿版:没必要写这么多东西,还是尽量浓缩成一页,自我评价,git和cursor Trae这些都可以去掉。实习经历的描述最好根据star法则改一下,别这么直白
点赞 评论 收藏
分享
02-08 20:56
已编辑
南京工业大学 Java
在等offer的比尔很洒脱:我也是在实习,项目先不说,感觉有点点小熟悉,但是我有点疑问,这第一个实习,公司真的让实习生去部署搭建和引入mq之类的吗,是不是有点过于信任了,我实习过的两个公司都是人家正式早搭好了,根本摸不到部署搭建的
点赞 评论 收藏
分享
评论
点赞
收藏
分享

创作者周榜

更多
牛客网
牛客企业服务