PAT-A 1007. Maximum Subsequence Sum

Given a sequence of K integers { N1, N2, …, NK }. A continuous subsequence is defined to be { Ni, Ni+1, …, Nj } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

程序代码:

#include<stdio.h>
#define MAX 10000
int main()
{
    int num[MAX];
    int value[MAX]={0};
    int n,i;
    scanf("%d",&n);
    for(i=0;i<n;i++)
    {
        scanf("%d",&num[i]);
    }
    value[0] = num[0];
    int start[MAX]= {0};
    int end = 0;
    int max = value[0];
    start[0];
    for(i=1;i<n;i++)
    {
        if(value[i-1]>0)
        {
            value[i] = value[i-1]+num[i];
            start[i] = start[i-1];
        }
        else
        {
            value[i] = num[i];
            start[i] = i;
        }
        if(max<value[i])
        {
            max = value[i];
            end = i;
        }
    }
    if(max<0)
        printf("0 %d %d",num[0],num[n-1]);
    else
        printf("%d %d %d",max,num[start[end]],num[end]);
    return 0;
}
全部评论

相关推荐

10-13 17:47
门头沟学院 Java
wulala.god:图一那个善我面过,老板网上找的题库面的
点赞 评论 收藏
分享
点赞 收藏 评论
分享
牛客网
牛客企业服务