PAT-A 1094. The Largest Generation

1094. The Largest Generation

A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (<100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a family member, K (>0) is the number of his/her children, followed by a sequence of two-digit ID’s of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.

Sample Input:

23 13
21 1 23
01 4 03 02 04 05
03 3 06 07 08
06 2 12 13
13 1 21
08 2 15 16
02 2 09 10
11 2 19 20
17 1 22
05 1 11
07 1 14
09 1 17
10 1 18

Sample Output:

9 4

这道题其实考的是图的BFS遍历,如果当成树来看的话会比较麻烦,因为孩子的个数是不确定的。还是看成一个特殊的图来看待比较方便。C++当中有很多很好用的容器,比如queue、stack等等,可怜我之前用C,全部都要自己写,真是蠢到姥姥家了。这道题比较麻烦的是计算每一层的结点个数,用两重for循环可以解决这个问题。

程序代码:

#include<iostream>
using namespace std;
#define MAX 100
#include<queue>
#include<vector>
vector <int> num[MAX];
bool visited[MAX]={0};
void BFS(int s);
int sum = 0;
int max_level =1;
int main()
{
    int N,M; //N总人数,M有孩子的人数
    cin>>N>>M;
    int ID,k;
    int tmp;
    for(int i=0;i<M;i++)
    {
        cin>>ID>>k;
        for(int j=0;j<k;j++)
        {
            cin>>tmp;
            num[ID].push_back(tmp);             
        }
    }
    BFS(1);
    cout<<sum<<" "<<max_level;
    return 0;
}
void BFS(int s)
{
    int level =1;
    //max_level = 1;
    int cnt,cnt1=1;
    //max = 0;
    queue<int> q;
    q.push(s);
    visited[s]=true;
    int tmp;
    while(!q.empty())
    {
        cnt=cnt1;
        cnt1=0;
        if(cnt>sum)
        {
            sum = cnt;
            max_level = level;
        }
        for(int j=0;j<cnt;j++)
        {
            tmp = q.front();
            q.pop();
            visited[tmp]= true;
            for(int i=0;i<num[tmp].size();i++)
            {
                q.push(num[tmp][i]);
                cnt1++;
            }
        }
        level++;
    }
}
全部评论

相关推荐

10-17 12:16
同济大学 Java
7182oat:快快放弃了然后发给我,然后让我也泡他七天最后再拒掉,狠狠羞辱他一把😋
点赞 评论 收藏
分享
10-09 22:05
666 C++
找到工作就狠狠玩CSGO:报联合国演讲,报电子烟设计与制造
点赞 评论 收藏
分享
秋招进行到现在终于能写总结了。完全没想到战线会拉这么长,过程会如此狼狈,不过更应该怪自己太菜了。好在所有的运气都用在了最后,也是有个去处。背景:双2本硕科班,无竞赛,本科一段研究所实习,硕士一段大厂暑期实习但无转正。技术栈是C++&nbsp;&amp;&nbsp;Golang,实习是客户端音视频(而且是鸿蒙端开发),简历两个C++项目一个Golang项目。主要投递岗位:后端,cpp软开,游戏服务端,测开,以及一些不拘泥于Java的岗位。从8月起总共投递123家公司,笔试数不清了,约面大约30家。offer/oc/意向:友塔游戏(第一个offer,面试体验很好,就是给钱好少南瑞继保(计算机科班点击就送(限男生),不...
乡土丁真真:佬很厉害,羡慕~虽然我还没有到校招的时候,也想讲一下自己的看法:我觉得不是CPP的问题,佬的背书双2,技术栈加了GO,有两段实习。投了123,面了30.拿到11个offer。这个数据已经很耀眼了。这不也是CPP带来的吗?当然也不止是CPP。至少来说在这个方向努力过的也会有好的结果和选择。同等学历和项目选java就会有更好的吗?我个人持疑问态度。当然CPP在方向选择上确实让人头大,但是我觉得能上岸,至于最后做什么方向,在我看来并不重要。至于CPP特殊,有岗位方向的随机性,java不是不挑方向,只是没得选而已。也希望自己以后校招的时候能offer满满
点赞 评论 收藏
分享
评论
点赞
收藏
分享
牛客网
牛客企业服务