HDU 6124 Euler theorem

Problem Description

HazelFan is given two positive integers a,b, and he wants to calculate amodb. But now he forgets the value of b and only remember the value of a, please tell him the number of different possible results.

Input

The first line contains a positive integer T(1≤T≤5), denoting the number of test cases. 
For each test case: 
A single line contains a positive integer a(1≤a≤109).

Output

For each test case: 
A single line contains a nonnegative integer, denoting the answer.

Sample Input



3

Sample Output


3

题目大意:

输入一个数n,有n组测试数据,输入A,求A%B有几种可能,B可以为任意值。 
这是一个规律题,可以先用暴力求出正确答案,再观察规律。这道题的规律是 
d=(b-1)/2+2或d=(b+1)/2+1。d为结果,b为输入值

c++

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int main()
{
    long long int a,b,c,d,e,f;
    cin>>a;
    while(a--)
    {
        cin>>b;
        d=(b-1)/2+2;
        cout<<d<<endl;
    }
    return 0;
}




全部评论

相关推荐

11-24 00:11
已编辑
广东工业大学 算法工程师
避雷深圳&nbsp;&nbsp;yidao,试用期&nbsp;6&nbsp;个月。好嘛,试用期还没结束,就直接告诉你尽快找下一家吧,我谢谢您嘞
牛客75408465号:笑死,直属领导和 hr 口径都没统一,各自说了一些离谱的被裁理由,你们能不能认真一点呀,哈哈哈哈哈😅😅😅
点赞 评论 收藏
分享
喜欢走神的孤勇者练习时长两年半:池是池,发是发,我曾池,我现黑
点赞 评论 收藏
分享
10-17 10:05
已编辑
北华大学 全栈开发
牛客872465272号:掉头发了哥
点赞 评论 收藏
分享
评论
点赞
收藏
分享
牛客网
牛客企业服务