HDU 6124 Euler theorem

Problem Description

HazelFan is given two positive integers a,b, and he wants to calculate amodb. But now he forgets the value of b and only remember the value of a, please tell him the number of different possible results.

Input

The first line contains a positive integer T(1≤T≤5), denoting the number of test cases. 
For each test case: 
A single line contains a positive integer a(1≤a≤109).

Output

For each test case: 
A single line contains a nonnegative integer, denoting the answer.

Sample Input



3

Sample Output


3

题目大意:

输入一个数n,有n组测试数据,输入A,求A%B有几种可能,B可以为任意值。 
这是一个规律题,可以先用暴力求出正确答案,再观察规律。这道题的规律是 
d=(b-1)/2+2或d=(b+1)/2+1。d为结果,b为输入值

c++

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int main()
{
    long long int a,b,c,d,e,f;
    cin>>a;
    while(a--)
    {
        cin>>b;
        d=(b-1)/2+2;
        cout<<d<<endl;
    }
    return 0;
}




全部评论

相关推荐

04-03 13:58
上海大学 Java
3月15号笔的,1-AC\2-90%\3-60%\4-AC泡了半个月今天早上起来看不通过,到底是谁在面试网易啊
只会CV的高级程序员:你a不过 你是985也找你面试 不太懂现在用人单位到底怎么想的 建议不用笔试 直接每个985都招就行了 挂科的退学的
投递网易等公司6个岗位 >
点赞 评论 收藏
分享
02-16 13:52
门头沟学院 Java
给🐭🐭个面试机会吧:嘿,mvbatis
点赞 评论 收藏
分享
点赞 评论 收藏
分享
评论
点赞
收藏
分享

创作者周榜

更多
牛客网
牛客企业服务