HDU 1711 Number Sequence
Problem Description
Given two sequences of numbers : a[1], a[2], …… , a[N], and b[1], b[2], …… , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], …… , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], …… , a[N]. The third line contains M integers which indicate b[1], b[2], …… , b[M]. All integers are in the range of [-1000000, 1000000].
Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
Sample Input
2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1
Sample Output
6
-1
题目大意:
给定两个数组,问能不能再第一个数组中匹配得到第二个数组,如果可以,那么输出最早匹配的起始位置,否则输出-1。
C++
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int N=10010;
int arr1[N*100],arr2[N],nt[N];
int n,m,s;
void getnt()
{
int i = 0, j = -1;
nt[0] = -1;
while(i < m)
{
if(j == -1 || arr2[i] == arr2[j])
{
i++, j++;
nt[i] = j;
}
else j = nt[j];
}
}
int kmp()
{
getnt();
int i = 0, j = 0;
s=-1;
while(i < n)
{
if(j == -1 || arr1[i] == arr2[j])
i++, j++;
else
j = nt[j];
if(j == m)
{
s=i-m+1;
break;
}
}
return s;
}
int main()
{
int t;
scanf("%d", &t);
while(t--)
{
scanf("%d%d", &n, &m);
for(int i = 0; i < n; i++)
scanf("%d", &arr1[i]);
for(int i = 0; i < m; i++)
scanf("%d", &arr2[i]);
if(n < m) printf("-1\n");
else cout<<kmp()<<endl;
}
return 0;
}