暑期集训3:几何基础 练习题C: POJ - 1269

2018学校暑期集训第三天——几何基础

练习题B ——  POJ - 1269

Intersecting Lines


We all know that a pair of distinct points on a plane defines a line and that a pair of lines on a plane will intersect in one of three ways: 1) no intersection because they are parallel, 2) intersect in a line because they are on top of one another (i.e. they are the same line), 3) intersect in a point. In this problem you will use your algebraic knowledge to create a program that determines how and where two lines intersect. 
Your program will repeatedly read in four points that define two lines in the x-y plane and determine how and where the lines intersect. All numbers required by this problem will be reasonable, say between -1000 and 1000. 

Input

The first line contains an integer N between 1 and 10 describing how many pairs of lines are represented. The next N lines will each contain eight integers. These integers represent the coordinates of four points on the plane in the order x1y1x2y2x3y3x4y4. Thus each of these input lines represents two lines on the plane: the line through (x1,y1) and (x2,y2) and the line through (x3,y3) and (x4,y4). The point (x1,y1) is always distinct from (x2,y2). Likewise with (x3,y3) and (x4,y4).

Output

There should be N+2 lines of output. The first line of output should read INTERSECTING LINES OUTPUT. There will then be one line of output for each pair of planar lines represented by a line of input, describing how the lines intersect: none, line, or point. If the intersection is a point then your program should output the x and y coordinates of the point, correct to two decimal places. The final line of output should read "END OF OUTPUT".

Sample Input

5
0 0 4 4 0 4 4 0
5 0 7 6 1 0 2 3
5 0 7 6 3 -6 4 -3
2 0 2 27 1 5 18 5
0 3 4 0 1 2 2 5

Sample Output

INTERSECTING LINES OUTPUT
POINT 2.00 2.00
NONE
LINE
POINT 2.00 5.00
POINT 1.07 2.20
END OF OUTPUT

#include<iostream>
#include<cstdio>
using namespace std;

int main(void)
{
	double x1, x2, x3, x4;
	double y1, y2, y3, y4;
	double k1, k2, b1, b2;
	int n;
	cin >> n;
	cout << "INTERSECTING LINES OUTPUT" << endl;
	while(n--){
		scanf("%lf%lf%lf%lf", &x1, &y1, &x2, &y2);
		scanf("%lf%lf%lf%lf", &x3, &y3, &x4, &y4);
		if(x1==x2 && x3==x4){
			if(x1==x3)
				cout << "LINE" << endl;
			else
				cout << "NONE" << endl;
			//continue;
		}else if(x1==x2 && x3!=x4){
			k2 = (y4-y3)/(x4-x3);
			b2 = y3 - k2*x3;
			printf("POINT %.2lf %.2lf\n", x1, k2*x1+b2);
			//continue;
		}else if(x3==x4 && x1!=x2){
			k1 = (y2-y1)/(x2-x1);
			b1 = y1 - k1*x1;
			printf("POINT %.2lf %.2lf\n", x3, k1*x3+b1);
			//continue;
		}else{
			k1 = (y2-y1)/(x2-x1);
			b1 = y1 - k1*x1;
			k2 = (y4-y3)/(x4-x3);
			b2 = y3 - k2*x3;
			if(k1==k2){
				if(b1==b2)
					cout << "LINE" << endl;
				else
					cout << "NONE" << endl;
			}else{
				double x = (b2-b1)/(k1-k2);
				printf("POINT %.2lf %.2lf\n", x, k1*x+b1);
			}
		}	
	}
	cout << "END OF OUTPUT";
	
	return 0;
}

 

全部评论

相关推荐

01-14 12:08
门头沟学院 Java
神哥了不得:(非引流)1.既然发出来了简历,就稍微提一点点小建议,确实简历很不错了,练手项目可以换一些质量高的,工作内容,可以加上一些量化指标,比如第一条系统响应速度由多少变成多少,减少了百分之多少,第4条就很不错。2.广投,年前实习招募比较少了
点赞 评论 收藏
分享
评论
点赞
收藏
分享

创作者周榜

更多
牛客网
牛客企业服务