1513.K.Reversed Words SDNUOJ 1513

Description
Some aliens are learning English. They have a very strange way in writing that they revered every word in the sentence but keep all the words in common order. For example when they want to write “one two three”, they will write down “eno owt eerht”.

Now we’ve got some sentence written by these aliens, translate them! And maybe we will know some of their secrets!

Input
Multiple test cases. The first line contains a positive integer T (T <= 1000), indicating the number of test cases.

For each test cases, there will be one line contains only lower case letters and spaces. The length of each line will be no more than 10000. Test cases which are longer than 5000 will be less than 50. Continuous letters are seen as a word, words are separated by spaces. There won’t be two adjacent spaces in the input. Space won’t be the first or the last character.

Output
One line per case, the translated sentence.

Sample Input
2
eno owt eerht
abcde
Sample Output
one two three
edcba

用vector卡住了…

#include <cstdio>
#include <iostream>
#include <cstring>
using namespace std;

int main()
{
    int t;
    while(cin >> t)
    {
        getchar();
        while(t--)
        {

                char s[10005];
                gets(s);
//                cout << s << '\n';
                int len = strlen(s);
//                cout << len << '\n';
                int start = 0;
                int over;
                for(int j = 0; j <= len; j++)
                {
                    if(s[j] == ' ' || j == len)
                    {
                        for(int k = j - 1; k >= start; --k)
                        {
                            cout << s[k];
                        }
                        if(j != len)
                            cout << " ";
                        start = j + 1;
                    }
                }
                cout << '\n';

        }
    }
    return 0;
}

全部评论

相关推荐

10-17 17:14
门头沟学院 C++
牛客410039819号:北京地区大多是919和927,这两场挂太多人了
投递华为等公司10个岗位
点赞 评论 收藏
分享
贺兰星辰:不要漏个人信息,除了简历模板不太好以外你这个个人简介是不是太夸大了...
点赞 评论 收藏
分享
评论
点赞
收藏
分享
牛客网
牛客企业服务