1135.Phone Number SDNUOJ 1135

Description
We know that if a phone number A is another phone number B’s prefix, B is not able to be called. For an example, A is 123 while B is 12345, after pressing 123, we call A, and not able to call B.
Given N phone numbers, your task is to find whether there exits two numbers A and B that A is B’s prefix.
Input
The input consists of several test cases.
The first line of input in each test case contains one integer N (0<N<1001), represent the number of phone numbers.
The next line contains N integers, describing the phone numbers.
The last case is followed by a line containing one zero.
Output
For each test case, if there exits a phone number that cannot be called, print “NO”, otherwise print “YES” instead.
Sample Input
2
012
012345
2
12
012345
0
Sample Output
NO
YES

#include <iostream>
#include <string>
using namespace std;

string s[1005];

int main()
{
    int n;
    while(cin >> n)
    {
        if(n == 0)
            break;
        for(int i = 0; i < n; ++i)
            cin >> s[i];
        for(int i = 0; i < n; ++i)
            for(int j = i + 1; j < n ; ++j)///find是全匹配,find_first_of不是
                if(s[i].find(s[j], 0) == 0 || s[j].find(s[i], 0) == 0)
                    goto END;///goto无条件语句
        cout << "YES" << '\n';
        continue;///幸亏有continue跳过了END
END :
        cout << "NO" << '\n';
    }
    return 0;
}

全部评论

相关推荐

面试摇了我吧:啊哈哈面试提前五个小时发,点击不能参加就是放弃
点赞 评论 收藏
分享
10-13 17:47
门头沟学院 Java
wulala.god:图一那个善我面过,老板网上找的题库面的
点赞 评论 收藏
分享
评论
点赞
收藏
分享
牛客网
牛客企业服务