Catch That Cow POJ3278
Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.
- Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
- Teleporting: FJ can move from any point X to the point 2 × X in a single minute.
If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
Input
Line 1: Two space-separated integers: N and K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
#include <iostream>
#include <queue>
#include <cstring>
using namespace std;
const int N = 1e5;
struct node
{
int x, step;
} start, over;
bool vis[N + 5];///漏了就超时
void bfs(node start, node over)
{
queue<node> q;
q.push(start);
vis[start.x] = 1;
while(!q.empty())
{
start = q.front();
q.pop();
if(start.x == over.x)
{
cout << start.step << '\n';
return ;
}
node tem;
tem.x = start.x - 1;
if(tem.x >= 0 && tem.x <= N && vis[tem.x] == 0 )
{
vis[tem.x] = 1;
tem.step = start.step + 1;
q.push(tem);
}
tem.x = start.x + 1;
if(tem.x >= 0 && tem.x <= N && vis[tem.x] == 0 )
{
vis[tem.x] = 1;
tem.step = start.step + 1;
q.push(tem);
}
tem.x = start.x * 2;
if(tem.x >= 0 && tem.x <= N && vis[tem.x] == 0 )
{
vis[tem.x] = 1;
tem.step = start.step + 1;
q.push(tem);
}
}
return ;
}
int main()
{
int n, k;
while(~scanf("%d%d", &n, &k))
{
start.x = n;
over.x = k;
bfs(start, over);
memset(vis, 0, sizeof(vis));///在bfs、dfs里很重要
}
return 0;
}