问题 B: Balanced Neighbors(思维)

时间限制: 1 Sec 内存限制: 128 MB
提交: 72 解决: 37
[提交] [状态] [命题人:admin]
题目描述
You are given an integer N. Build an undirected graph with N vertices with indices 1 to N that satisfies the following two conditions:
·The graph is simple and connected.
·There exists an integer S such that, for every vertex, the sum of the indices of the vertices adjacent to that vertex is S.
It can be proved that at least one such graph exists under the constraints of this problem.

Constraints
·All values in input are integers.
·3≤N≤100

输入
Input is given from Standard Input in the following format:

N

输出
In the first line, print the number of edges, M, in the graph you made. In the i-th of the following M lines, print two integers ai and bi, representing the endpoints of the i-th edge.
The output will be judged correct if the graph satisfies the conditions.

样例输入
复制样例数据
3
样例输出
2
1 3
2 3

提示
For every vertex, the sum of the indices of the vertices adjacent to that vertex is 3.

先画出完全图,发现删边规律


#include<iostream>
using namespace std;
int dp[109][109];
int a[1009];
 
int main(){
	int n;
	scanf("%d",&n);
	if(n%2==0){
		cout<<n*(n-1)/2-n/2<<endl;
		for(int i=1;i<=n;i++){
			dp[i][n-i+1]=1;
		}
	}
	else{
		cout<<n*(n-1)/2-(n-1)/2<<endl;
		for(int i=1;i<=n-1;i++){
			dp[i][n-i]=1;
		}
	}
	for(int i=1;i<=n;i++){
		for(int j=i+1;j<=n;j++){
			if(dp[i][j]==0) printf("%d %d\n",i,j);
		}
	}
} 
全部评论

相关推荐

赏个offer求你了:友塔HR还专门加我告诉我初筛不通过😂
点赞 评论 收藏
分享
评论
点赞
收藏
分享
正在热议
# 25届秋招总结 #
441069次浏览 4495人参与
# 春招别灰心,我们一人来一句鼓励 #
41545次浏览 524人参与
# 北方华创开奖 #
107340次浏览 599人参与
# 地方国企笔面经互助 #
7937次浏览 18人参与
# 同bg的你秋招战况如何? #
75837次浏览 554人参与
# 虾皮求职进展汇总 #
114640次浏览 885人参与
# 阿里云管培生offer #
119983次浏览 2219人参与
# 实习,投递多份简历没人回复怎么办 #
2454217次浏览 34849人参与
# 实习必须要去大厂吗? #
55703次浏览 960人参与
# 提前批简历挂麻了怎么办 #
149846次浏览 1977人参与
# 投递实习岗位前的准备 #
1195775次浏览 18547人参与
# 你投递的公司有几家约面了? #
33182次浏览 188人参与
# 双非本科求职如何逆袭 #
661978次浏览 7394人参与
# 如果公司给你放一天假,你会怎么度过? #
4734次浏览 55人参与
# 机械人春招想让哪家公司来捞你? #
157608次浏览 2267人参与
# 如果你有一天可以担任公司的CEO,你会做哪三件事? #
11417次浏览 276人参与
# 发工资后,你做的第一件事是什么 #
12467次浏览 61人参与
# 工作中,努力重要还是选择重要? #
35657次浏览 384人参与
# 参加完秋招的机械人,还参加春招吗? #
20096次浏览 240人参与
# 我的上岸简历长这样 #
451947次浏览 8088人参与
# 实习想申请秋招offer,能不能argue薪资 #
39252次浏览 314人参与
# 非技术岗是怎么找实习的 #
155859次浏览 2120人参与
牛客网
牛客企业服务