Saruman's Army

Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range of R units, and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within R units of some palantir.

Input

The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positions x1, …, xnof each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n = −1.

Output

For each test case, print a single integer indicating the minimum number of palantirs needed.

Sample Input

0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1

Sample Output

2
4

Hint

In the first test case, Saruman may place a palantir at positions 10 and 20. Here, note that a single palantir with range 0 can cover both of the troops at position 20.

In the second test case, Saruman can place palantirs at position 7 (covering troops at 1, 7, and 15), position 20 (covering positions 20 and 30), position 50, and position 70. Here, note that palantirs must be distributed among troops and are not allowed to “free float.” Thus, Saruman cannot place a palantir at position 60 to cover the troops at positions 50 and 70.

C++版本一

贪心算法

#include <iostream>
#include <stdio.h>
#include <cstring>
#include <algorithm>


using namespace std;
int r,n,ans;
int a[1100];
bool f[1100];

int main()
{
    while(scanf("%d%d",&r,&n)!=EOF){
        if(r==-1&&n==-1)break;
        for(int i=0;i<n;i++){
            scanf("%d",&a[i]);
        }
        sort(a, a+n);
        //for(int i=0;i<n;i++){
        //    printf("%d",a[i]);
        //}
        ans=0;
        int cur,ent;
        memset(f,false,sizeof(f));
        for(int i=0;i<n;i++){
                ans++;
                cur=i;
                ent=i;
                if(!f[i]){
                    f[i]=true;
                    for(int j=i+1;j<n;j++){
                        if(a[i]+r>=a[j]){
                            cur=j;
                            f[j]=true;
                        }else{
                            break;
                        }
                    }
                    ent=cur;
                    for(int j=cur+1;j<n;j++){
                        if(a[cur]+r>=a[j]){
                            f[j]=true;
                            ent=j;
                        }else{
                            break;
                        }
                    }
                    i=ent;
                }
        }
        cout << ans << endl;
    }
    //cout << "Hello world!" << endl;
    return 0;
}

 

全部评论

相关推荐

ProMonkey2024:5个oc?厉害! 但是有一个小问题:谁问你了?😡我的意思是,谁在意?我告诉你,根本没人问你,在我们之中0人问了你,我把所有问你的人都请来 party 了,到场人数是0个人,誰问你了?WHO ASKED?谁问汝矣?誰があなたに聞きましたか?누가 물어봤어?我爬上了珠穆朗玛峰也没找到谁问你了,我刚刚潜入了世界上最大的射电望远镜也没开到那个问你的人的盒,在找到谁问你之前我连癌症的解药都发明了出来,我开了最大距离渲染也没找到谁问你了我活在这个被辐射蹂躏了多年的破碎世界的坟墓里目睹全球核战争把人类文明毁灭也没见到谁问你了(别的帖子偷来的,现学现卖😋)
点赞 评论 收藏
分享
评论
点赞
收藏
分享
牛客网
牛客企业服务