Saruman's Army

Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range of R units, and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within R units of some palantir.

Input

The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positions x1, …, xnof each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n = −1.

Output

For each test case, print a single integer indicating the minimum number of palantirs needed.

Sample Input

0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1

Sample Output

2
4

Hint

In the first test case, Saruman may place a palantir at positions 10 and 20. Here, note that a single palantir with range 0 can cover both of the troops at position 20.

In the second test case, Saruman can place palantirs at position 7 (covering troops at 1, 7, and 15), position 20 (covering positions 20 and 30), position 50, and position 70. Here, note that palantirs must be distributed among troops and are not allowed to “free float.” Thus, Saruman cannot place a palantir at position 60 to cover the troops at positions 50 and 70.

C++版本一

贪心算法

#include <iostream>
#include <stdio.h>
#include <cstring>
#include <algorithm>


using namespace std;
int r,n,ans;
int a[1100];
bool f[1100];

int main()
{
    while(scanf("%d%d",&r,&n)!=EOF){
        if(r==-1&&n==-1)break;
        for(int i=0;i<n;i++){
            scanf("%d",&a[i]);
        }
        sort(a, a+n);
        //for(int i=0;i<n;i++){
        //    printf("%d",a[i]);
        //}
        ans=0;
        int cur,ent;
        memset(f,false,sizeof(f));
        for(int i=0;i<n;i++){
                ans++;
                cur=i;
                ent=i;
                if(!f[i]){
                    f[i]=true;
                    for(int j=i+1;j<n;j++){
                        if(a[i]+r>=a[j]){
                            cur=j;
                            f[j]=true;
                        }else{
                            break;
                        }
                    }
                    ent=cur;
                    for(int j=cur+1;j<n;j++){
                        if(a[cur]+r>=a[j]){
                            f[j]=true;
                            ent=j;
                        }else{
                            break;
                        }
                    }
                    i=ent;
                }
        }
        cout << ans << endl;
    }
    //cout << "Hello world!" << endl;
    return 0;
}

 

全部评论

相关推荐

11-09 14:54
已编辑
华南农业大学 产品经理
大拿老师:这个简历,连手机号码和照片都没打码,那为什么关键要素求职职位就不写呢? 从上往下看,都没看出自己到底是产品经理的简历,还是电子硬件的简历? 这是一个大问题,当然,更大的问题是实习经历的描述是不对的 不要只是去写实习流程,陈平,怎么去开会?怎么去讨论? 面试问的是你的产品功能点,是怎么设计的?也就是要写项目的亮点,有什么功能?这个功能有什么难处?怎么去解决的? 实习流程大家都一样,没什么优势,也没有提问点,没有提问,你就不得分 另外,你要明确你投的是什么职位,如果投的是产品职位,你的项目经历写的全都是跟产品无关的,那你的简历就没用 你的面试官必然是一个资深的产品经理,他不会去问那些计算机类的编程项目 所以这种四不像的简历,在校招是大忌
点赞 评论 收藏
分享
11-27 17:08
已编辑
牛客_产品运营部_私域运营
腾讯 普通offer 24k~26k * 15,年包在36w~39w左右。
点赞 评论 收藏
分享
评论
点赞
收藏
分享
牛客网
牛客企业服务